Forum Upgrade

  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

There may be some brief downtime and interruptions over the next many hours going into later today. I am doing a full upgrade to the latest PHPBB (I have only been doing security fixes since (2.0.6) and fixing a few bugs with our current system read tracking as reported by users. I will post another message once this upgrade is complete as well as the details on the changes/fixes I have done.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

How's it coming chief? The supermod Admin CP still shows the old version, so I take it you didn't get finished last night?
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Yeah I didn't get it finished last night because of a new bug I had discovered with the new setup. I wanted to get that resolved first.
  • SB
  • Moderator
  • Genius
  • User avatar
  • Posts: 8742
  • Loc: Aberdeen, Scotland

Post 3+ Months Ago

I am guessing that because the site was down about 5 minutes ago was because of the upgrade?

If not, then i think you might have another problem on your hands BWM. I kept getting messages saying "This board is unavailable right now, please try again later" then it went to the folder directory for a minute or so. Seems fine at the moment.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Yes that was me. The major upgrade is now complete. I am just touching up on smaller issues now. I will make another post soon with everything that has been changed. There are bug fixes and a few new features in this upgrade!
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

I believe I have almost everything straightened out now. As I have mentioned before in the past I was only doing security updates, but this upgrade was a full upgrade to the latest version of PHPBB which includes all of the other updates to phpbb that weren't security threats.

In addition the tracking system which tracks read and unread posts have been updated and hopefully resolves some problems. More specfically the upgrade solves the bugs that sometimes gave a user an unread flag on his or her own posts, sometimes gave a user an unread flag on other posts that he or she had already read and sometimes caused a user to lose all unread flags. The upgrade keeps unread flags beyond the current page of a topic until the user actually visits that page. Also a NEW FEATURE: the upgrade gives the user a new icon on each post (right next to the quote button) that allows the user to mark the topic unread again from that post onwards (a sort of bookmark function). Here is a screenshot showing where it is:

Image

Also in this update I added some more words to the spell checker. This includes:

ozzu
website
I'm
webmaster
html
php
javascript

Another important fix is that there have been some new members having problems seeing the visual confirmation code when signing up at ozzu. I believe this full update to the latest version of PHPBB should resolve this. This should enable more members who want to signup at ozzu to actually make it completely through the signup process.

For the most part everything else is the same. One major new feature, and many bug fixes.

If you experience any problems, or notice anything out of whack please post to this thread or PM me so that I can resolve it. Thanks!
  • whatlikesit12345
  • Guru
  • Guru
  • User avatar
  • Posts: 1211

Post 3+ Months Ago

thats pritty sweet.

just as i was reading this topic i noticed the new button. i guess this forum may of needed it but who knows.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

So far everything seems to be OK on the read tracking, boss. I switched from IE to Firefox on the same IP, and switched IP's and checked 3 different computers and all seem to be showing the same read tracking.

It occurred to me while performing this test, that it may have been possible that at least some of the prior read tracking issues may have been due to the fact that I never closed down any browsers on any of my computers prior to your upgrade, hence I never picked up a new session. So I'm wondering if that may have been some of what people were experiencing. I'll play around a bit with that again tomorrow.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

As an aside, I tried the Mark post as unread thing you added on one computer and came back to this one and it now shows as unread. Looks like your update might have taken care of the read tracking from what I can tell so far.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Good, I tested this thoroughly so I am hoping I didn't miss anything. I actually had found one bug but got it resolved before I went live with it.
  • musik
  • Legend
  • Super Moderator
  • User avatar
  • Posts: 6893
  • Loc: up a tree

Post 3+ Months Ago

My read unread posts is working much better today, there is 3 pages from overnight, usually it shows barely a page although there are lots of unread posts. Will let you know again in a few days if its still working good :D
  • LAbrego
  • brego from LA
  • Web Master
  • User avatar
  • Posts: 2855

Post 3+ Months Ago

Pretty much the same here BWM, everything is working ok, aside of two or three fall downs yesterday (I thought it has to be your upgrade) everything is ok on my side. Congrats BWM.
  • LAbrego
  • brego from LA
  • Web Master
  • User avatar
  • Posts: 2855

Post 3+ Months Ago

I feel the forums a little bit slower than before, what usually took 1 or 2 seconds, now is taking 3 or 4. When I open a topic and try to scroll down, it stops for a second or two and then paints te rest of the window. I tell you in a while if this is a problem of my side, I just wanted to know if someone else is having the same delay.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

It's not on your side. It's something Bigwebmaster is aware of and working to correct.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

It is not related to the upgrade however. This has been a server problem we have been facing the last month. The problem is because of the excessive traffic the forum is getting and at times the load will shoot higher and slow everything down for users. The fact we currently are sharing this server with many other websites we run isn't helping and the best way to resolve that problem would be to probably isolate ozzu on its own server.
  • LAbrego
  • brego from LA
  • Web Master
  • User avatar
  • Posts: 2855

Post 3+ Months Ago

Thanks ATNO, is good to know I am not the only one.

BWM if you need donations to get Ozzu its own server you can count on mine ;)
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Well I appreciate that comment Larz. The best donation anybody can give is to simply be a part of the community at ozzu and help each other out. That is what ozzu is all about.

The advertising on ozzu could totally support the cost for a new server and then some. So funding is not a problem. I appreciate the remark nonetheless, and the good intentions you have to help make this a better community.
  • LAbrego
  • brego from LA
  • Web Master
  • User avatar
  • Posts: 2855

Post 3+ Months Ago

You're welcome BigWeb, I never would be able to pay everything that you have given to me, a new family.
  • Ishii
  • Proficient
  • Proficient
  • Ishii
  • Posts: 355
  • Loc: Gilbert, AZ

Post 3+ Months Ago

Bigwebmaster wrote:
The advertising on ozzu could totally support the cost for a new server and then some. So funding is not a problem.


This makes me wonder how greedy some other sites are with the amount of popups and banner adds they have. If you do end up needing donations (I know you said you didn't) count me in. The amount of knowledge on tap here is worth at least a couple pennies. :mrgreen:

Post Information

  • Total Posts in this topic: 19 posts
  • Users browsing this forum: No registered users and 2 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.