Favicon Not Working

  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

On my site gfxfor.us, i put up a favicon that i made in GIMP called Favicon.ico

However, when I do the code for including the favicon (I put it in header.php), all it shows is a black box. The white letter "G" is nowhere to be found.

What is going on and how can I fix it?
  • SB
  • Moderator
  • Genius
  • User avatar
  • Posts: 8745
  • Loc: Aberdeen, Scotland

Post 3+ Months Ago

How did you create the graphic? I don't think it has anything to do with the code you will have typed, but more to do with the actual graphic itself. Have you actually looked at the graphic since it was created online? What i mean is, have you maybe seen the graphic as a jpg or a gif file rather than the ico file?

What i would also suggest is if you use Photoshop at all, perhaps you should install the ico plugin. It just takes a minute to do this and it saves you alot of time when creating ico files rather than installing any unecessary software like the one you might installed. You can download this plugin by clicking here!
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

:|

GIMP is not unnecessary, and is one of the most powerful image editing programs in existance, rivaling photoshop. I dont have photoshop because I have linux.
  • SB
  • Moderator
  • Genius
  • User avatar
  • Posts: 8745
  • Loc: Aberdeen, Scotland

Post 3+ Months Ago

I guess i was wrong. I mis-understood what program you said you were using. At the time of posting that i can't say i was in the best frame of mind.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23460
  • Loc: Woodbridge VA

Post 3+ Months Ago

nzk - It definitely seems to be a problem with the ico file itself, not the code. The code is perfect.

What steps did you take to create the image? Generally, you create a .bmp image and then use a bmp to ico converter, unless GIMP offers an option to save it in .ico format (I don't use it so I don't know if that's an option).

If you simply renamed a .bmp file to .ico it won't work.
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

GIMP has .ico option to save in
  • SB
  • Moderator
  • Genius
  • User avatar
  • Posts: 8745
  • Loc: Aberdeen, Scotland

Post 3+ Months Ago

I have found this website for you. I think this could be what you are looking for.

Creating Favicons on GIMP

Let me know if this has helped you. I'm not familier with the GIMP software, so i can only point you in the right direction.
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

My favicon made in GIMP isnt working, could anyone be kind enough to make me a quick little favicon? Its a white BG, on top is a black circle, then a white letter G

Thanks! I'll mention you on my site.
  • Tchuki
  • Mastermind
  • Mastermind
  • Tchuki
  • Posts: 1774
  • Loc: Edinburgh

Post 3+ Months Ago

http://www.chami.com/html-kit/services/favicon/
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

That site isnt working :(
  • Tchuki
  • Mastermind
  • Mastermind
  • Tchuki
  • Posts: 1774
  • Loc: Edinburgh

Post 3+ Months Ago

Download Here

Link to zipped fav, hope that is ok for you, if not holla back and let me know what you want amending.
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

Thanks!
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

If you could change something, Its just the transparency of the background. So that there isnt a white thing showing. Sorry for not mentioning that :)
  • Tchuki
  • Mastermind
  • Mastermind
  • Tchuki
  • Posts: 1774
  • Loc: Edinburgh

Post 3+ Months Ago

nzk wrote:
If you could change something, Its just the transparency of the background. So that there isnt a white thing showing. Sorry for not mentioning that :)


Ugh, the cheek of some people ;)

Link & image updated in previous post.

Hope thats better.
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

Hmm No change here. Sure you updated it?
  • Tchuki
  • Mastermind
  • Mastermind
  • Tchuki
  • Posts: 1774
  • Loc: Edinburgh

Post 3+ Months Ago

Yup, removed the white background.

In the folder named extra is a transparent version of the image. Take a gander in there.
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

Ahh, I only uploaded the favicon.ico in the main folder

Ill try that
  • nzk
  • Student
  • Student
  • User avatar
  • Posts: 77
  • Loc: NY

Post 3+ Months Ago

Awesome it works! Thanks. I'll put a link to your site on mine
  • flightie
  • Newbie
  • Newbie
  • flightie
  • Posts: 7
  • Loc: UK

Post 3+ Months Ago

Putting this in the head of each page worked for me:

Code: [ Select ]
<link rel="shortcut icon" href="favicon.ico" type="image/vnd.microsoft.icon">

Post Information

  • Total Posts in this topic: 19 posts
  • Users browsing this forum: No registered users and 8 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.