AS2 embeded sounds fail in imported swf.

  • eric_esdd
  • Born
  • Born
  • eric_esdd
  • Posts: 2

Post 3+ Months Ago

Using CS5 working in AS2, exporting to v10.swf

Have an existing site where I am using imported swf's to display images and animation, loading sound files at runtime into the parent swf. All goes well. main.swf loads child.swf to layer 50 then control_button.swf to layer 60.

I wanted to use loadClip/loadMovie to put imported swf to a layer below control buttons in the main.swf so as to avoid loading control_button.swf. I embedded sounds into child.swf trying to keep file count down and load required items in one hit. I have marked sound files export, marked link names and created newSound() and attached sounds.

Sound files play in child.swf stand-alone, but when imported into parent.swf there are animations in the child.swf but no sound.

The only way I can get the sound to play in the child.swf is to _root.loadMovie() but then I lose all other control and can't put it to a layer.

Assistance would be much appreciated.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • eric_esdd
  • Born
  • Born
  • eric_esdd
  • Posts: 2

Post 3+ Months Ago

Problem solved
var sf1:Sound = new Sound();
becomes: var sf1:Sound = new Sound(this);

Post Information

  • Total Posts in this topic: 2 posts
  • Users browsing this forum: No registered users and 17 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.