Assigning action to a menu button

  • Brookaneer
  • Born
  • Born
  • Brookaneer
  • Posts: 2

Post 3+ Months Ago

Hi,
Before I relate my problem, I think I should mention that I am a student from the university of trial and error and therefore anything too technical will go straight over my head.

I am able to resolve most things but the following has got me stumped.

I have created a header for a web site using macromedia flash mx. The header includes buttons to re-direct visitors to other pages within the website. I have used the 'get url' action to tell the browser to navigate to a specified url eg 'news.html' from the 'news button'

When I export the flash movie and then load my index page, immediately after the header has loaded, the news page is automatically loaded without clicking on the news button. In fact, it repeatedly loads until I 'X' out of the page.

Where I have gone wrong? How do I resolve it?

Any help you are able to give in simple step by step instructions would be gratefully received.

Thanks
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • classified
  • Expert
  • Expert
  • User avatar
  • Posts: 540
  • Loc: Bahrain

Post 3+ Months Ago

check your get URL function maybe one of em aint really in a function and left alone somewhere in the time line ...

also do check for errors ...

u can put in the code , or the fla , so we can have a look ...
  • CE/ creative studios
  • Newbie
  • Newbie
  • CE/ creative studios
  • Posts: 13
  • Loc: soCAL

Post 3+ Months Ago

make sure your news button is actually a button by clicking on the button on the stage and then going to the top and clicking on - modify - convert to symbol - button.

then after it is a button click on it and go to the actions. Now using the script assist on the right side of the actions window click: get url: as your action... fill in the url as:

http://www.wateveryoursiteis.com/news.html

click open in _self

....

peace,
nick
  • Brookaneer
  • Born
  • Born
  • Brookaneer
  • Posts: 2

Post 3+ Months Ago

Gentlemen,

Thank you for your time and suggestions. The request to 'Post the code' gave me the idea of having a look at it and sure enough there was the problem.

I had written the 'get URL' function (if that is the correct word) too early in the sequence of actions for the button. Therefore everytime the flash movie loaded, it immediatly loaded the requested page (news). I simply moved this piece of code to the end of the action sequence and just after the instruction to load the page on release of the mouse button.

'Look at the code' may seem the obvious thing to do, but sometimes you miss the obvious and that suggestion brought about the sucessful end.

Thanks

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 7 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.