Flash and background

  • virtualand
  • Novice
  • Novice
  • virtualand
  • Posts: 24

Post 3+ Months Ago

Hi,

I have this site http://www.vl-design.com

and I have a problem of browser compatibility

In IE the background of the flash sequencies are transparent, but in other browsers is black. How can I make it transparent as in IE?

Thank!
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6376
  • Loc: twitter.com/unflux

Post 3+ Months Ago

add this to the html code where you embeded the flash:
PHP Code: [ Select ]
<param name="wmode" value="transparent">

that will make the flash bg transparent for all browsers.
  • virtualand
  • Novice
  • Novice
  • virtualand
  • Posts: 24

Post 3+ Months Ago

But I use that.

The code is:

Code: [ Select ]
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="250" height="25" id="seq" align="middle">
 <param name="allowScriptAccess" value="sameDomain">
 <param name="movie" value="consola.swf">
 <param name="quality" value="High">
 <param name="bgcolor" value="000000">
 <param name="_cx" value="7170">
 <param name="_cy" value="6641">
 <param name="FlashVars" value>
 <param name="Src" value="consola.swf">
 <param name="WMode" value="Transparent">
 <param name="Play" value="-1">
 <param name="Loop" value="-1">
 <param name="SAlign" value>
 <param name="Menu" value="-1">
 <param name="Base" value>
 <param name="Scale" value="ShowAll">
 <param name="DeviceFont" value="0">
 <param name="EmbedMovie" value="0">
 <param name="SWRemote" value>
 <param name="MovieData" value>
 <param name="SeamlessTabbing" value="1">
 <embed src="consola.swf" quality="high" bgcolor="#000000" width="250" height="25" name="seq" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></object>
  1. <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="250" height="25" id="seq" align="middle">
  2.  <param name="allowScriptAccess" value="sameDomain">
  3.  <param name="movie" value="consola.swf">
  4.  <param name="quality" value="High">
  5.  <param name="bgcolor" value="000000">
  6.  <param name="_cx" value="7170">
  7.  <param name="_cy" value="6641">
  8.  <param name="FlashVars" value>
  9.  <param name="Src" value="consola.swf">
  10.  <param name="WMode" value="Transparent">
  11.  <param name="Play" value="-1">
  12.  <param name="Loop" value="-1">
  13.  <param name="SAlign" value>
  14.  <param name="Menu" value="-1">
  15.  <param name="Base" value>
  16.  <param name="Scale" value="ShowAll">
  17.  <param name="DeviceFont" value="0">
  18.  <param name="EmbedMovie" value="0">
  19.  <param name="SWRemote" value>
  20.  <param name="MovieData" value>
  21.  <param name="SeamlessTabbing" value="1">
  22.  <embed src="consola.swf" quality="high" bgcolor="#000000" width="250" height="25" name="seq" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></object>


In Firefox the background is black, in IE is transparent.
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6376
  • Loc: twitter.com/unflux

Post 3+ Months Ago

no idea why you have all those params, but I use the one I posted for you and it works just fine. Must be a conflict with all those other params. You really don't need them anyway.
  • virtualand
  • Novice
  • Novice
  • virtualand
  • Posts: 24

Post 3+ Months Ago

I reduce the code to:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="250" height="25" id="seq2" align="middle">
<param name="Src" value="consola.swf">
<param name="WMode" value="Transparent">
<embed src="consola.swf" quality="high" width="250" height="25" name="seq" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></object>

and still have a black background in firefox.

When you enter the site with firefox what do you see in the control panel of the music and sound?

in IE I see a transparent background, but with firefox is black even with less params.

Thanks!
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13504
  • Loc: Florida

Post 3+ Months Ago

Code: [ Select ]
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="250" height="25" id="seq2" align="middle">
 <param name="Src" value="consola.swf">
 <param name="WMode" value="Transparent">
 <embed src="consola.swf" quality="high" width="250" height="25" name="seq" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></object>
  1. <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="250" height="25" id="seq2" align="middle">
  2.  <param name="Src" value="consola.swf">
  3.  <param name="WMode" value="Transparent">
  4.  <embed src="consola.swf" quality="high" width="250" height="25" name="seq" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></object>


Look at the PARAMS then look at the attributes of your EMBED, notice anything different ?

wmode=transparent is missing from your EMBED tag :wink:
IE pulls from PARAMS , FFox pulls from EMBED attributes.
  • virtualand
  • Novice
  • Novice
  • virtualand
  • Posts: 24

Post 3+ Months Ago

HaHaHa! :lol:

It was that simple!!!!

It works fine... Thanks!

Regards
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6376
  • Loc: twitter.com/unflux

Post 3+ Months Ago

doh! I totally missed that because I was so distracted with all the other params tags! :lol:

good eye joebert. :D
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13504
  • Loc: Florida

Post 3+ Months Ago

UNFLUX wrote:
doh! I totally missed that because I was so distracted with all the other params tags! :lol:

good eye joebert. :D


I was tinkering with wmode right before I read this topic. :)
  • FusionDesigner
  • Proficient
  • Proficient
  • User avatar
  • Posts: 282

Post 3+ Months Ago

Code: [ Select ]
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="729" height="154">
  <param name="movie" value="futureisnow.swf">
  <param name="quality" value="high">
    <param name="wmode" value="transparent">
  <embed src="futureisnow.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="729" height="154" wmode="transparent" >
    
    </embed>
  1. <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="729" height="154">
  2.   <param name="movie" value="futureisnow.swf">
  3.   <param name="quality" value="high">
  4.     <param name="wmode" value="transparent">
  5.   <embed src="futureisnow.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="729" height="154" wmode="transparent" >
  6.     
  7.     </embed>


the transparency aint working in opera can you help. Spotted this post; thought its useful; so im adding to it. Its working now in IE and Netscape.
  • FusionDesigner
  • Proficient
  • Proficient
  • User avatar
  • Posts: 282

Post 3+ Months Ago

No one know?
  • digitalMedia
  • a.k.a. dM
  • Genius
  • User avatar
  • Posts: 5149
  • Loc: SC-USA

Post 3+ Months Ago

I don't think you can achieve a transparent window in Opera.
  • lostinbeta
  • Guru
  • Guru
  • User avatar
  • Posts: 1402
  • Loc: Philadelphia, PA

Post 3+ Months Ago

Correct, Opera does not yet support the transparent background.

For the browser that do support it, check here...

http://www.macromedia.com/support/flash ... /wmode.htm
  • FusionDesigner
  • Proficient
  • Proficient
  • User avatar
  • Posts: 282

Post 3+ Months Ago

Thanks; thats pretty lame by the Opera geeks :(
  • solidarity
  • Newbie
  • Newbie
  • solidarity
  • Posts: 5

Post 3+ Months Ago

Guess they have other things they'd rather put their energy on fixing. :)
  • beatngu
  • Born
  • Born
  • beatngu
  • Posts: 2

Post 3+ Months Ago

Mozilla and IE shows the following flash correctly, but my fellow colleagues using Linux dont have a transparant background viewing with Mozilla...

Any1 any experience with this? tx in advance,

Code: [ Select ]
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0"
 height="60"
 width="140">
<param name="src" value="qwer.swf"/>
<param name="wmode" value="transparent"/>
<param name="quality" value="High"/>
<param name="scale" value="exactfit"/>

<embed pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?p1_prod_version=shockwaveflash"
 type="application/x-shockwave-flash"
 src="eqwer.swf"
 wmode="transparent"
 height="90"
 width="140"
 quality="High" />
</object>
  1. <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
  2.  codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0"
  3.  height="60"
  4.  width="140">
  5. <param name="src" value="qwer.swf"/>
  6. <param name="wmode" value="transparent"/>
  7. <param name="quality" value="High"/>
  8. <param name="scale" value="exactfit"/>
  9. <embed pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?p1_prod_version=shockwaveflash"
  10.  type="application/x-shockwave-flash"
  11.  src="eqwer.swf"
  12.  wmode="transparent"
  13.  height="90"
  14.  width="140"
  15.  quality="High" />
  16. </object>

Post Information

  • Total Posts in this topic: 16 posts
  • Users browsing this forum: No registered users and 12 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.