looping back to previous frames

  • brettbash
  • Novice
  • Novice
  • User avatar
  • Posts: 16

Post 3+ Months Ago

im in the preocess of making an web page in flash. i have a little intro, home page, gallery, contact, etc....now the problem lies within my main buttons which are on everypage which link home and to gallery > so the navigational buttons. now on the main timeline in flash i have the homepage as the first page then to the gallery. then the gallery has subgalleries. i gave each button instance names and used that in the action script, i put it on the page frame for each page. so on the home page i would have put in the action panel :
stop();
gallery_btn.onRelease=function()
{
gotoAndPlay(9)
}
now when i get to the gallery the return home button will go back to the home page frame. the only problem is that when this happens, the audio from the into in the first frame plays. also in the subgalleries, i changed the frame that the gallery button is supposed to play, so it goes back and plays the gallery, and again plays the audio for the intro. what i think might be happening is that when the butto is going back to a previous frame on the timeline, it isplaying the into on the first frame in the background. another thing i noticed is when all of his started happening, the loading when i was testing the movie, it was loading longer than it should have.

so, if anyone has any suggestions, that would be very helpful.


also, i have another problem, not quit as big. when i go to test my movie i get an output error stating:

**Error** Symbol=body galley, layer=Layer 7, frame=71:Line 1: Statement must appear within on handler
stop();

Total ActionScript Errors: 1 Reported Errors: 1

now, there is a stop action on that frame, yet the error comes up, ive tried it without the stop();. ive tryied iit in a different layer on the same frame, but i still get the error. and the thing is with this problem, everything in this area works fine in the movie when i test it, so im not quite sure where it getting that error from
:?
  • brettbash
  • Novice
  • Novice
  • User avatar
  • Posts: 16

Post 3+ Months Ago

any help would be great

Post Information

  • Total Posts in this topic: 2 posts
  • Users browsing this forum: No registered users and 5 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.