Movie Clips Jamming

  • ryanbutler
  • Student
  • Student
  • ryanbutler
  • Posts: 86
  • Loc: Springfield, MO

Post 3+ Months Ago

New to this board and wondering if anyone could solve a mind boggling Flash issue for me? This address:

http://midwestwebdesign.net/temp/index.htm

As you roll over the the names of the buildings in the left hand column, the highlights show fine. But as you move progressively faster, the movie clips jam up. As far as I know, my action script is fine. For the life of me I cannot figure out what the deal is. I increased my frame rate and nothing changed. The only other solution I can think of is to put all my highlights in their own timeline, but this solution isn't working at the moment either. An original zip file is here:

http://midwestwebdesign.net/temp/tour.zip

If anyone would need to see it, no viruses promise. Never knew how hard Flash can be to learn. This problem is absolutely driving me up the wall. Any suggestions would greatly be appreciated.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • sevster
  • Bronze Member
  • Bronze Member
  • User avatar
  • Posts: 518

Post 3+ Months Ago

well, i know why this is happening, but i don't have time to give you details about it right now...

simply put, the faster you run the mouse, at some point, it's so fast that the program didn't recognize the mouse moving off of the object, and thus, even though it's off of it, it still thinks it's on it.

the reason for this? -- mediocre programming within the actionscript. therein lies your problem. messy code ( code which is not very efficient ) will cause such problems.

i'll look more into it later.
  • ryanbutler
  • Student
  • Student
  • ryanbutler
  • Posts: 86
  • Loc: Springfield, MO

Post 3+ Months Ago

Thanks for replying. Hmm...didn't think the action script was the problem. That's what I get for being an Action Script newbie. If it was ASP.NET or VB.NET I would know better. Would it help to add an onRollOut event as well? Any time you could spare in the near future would be appreciated. I'll keep looking for ways to improve it.

//*apparently after experimentation adding a frame rate of 30 helps some. But I believe the original poster is correct, my code isn't quite acting right yet//*

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 9 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.