Paths to multiple movie clips

  • Endorphin
  • Born
  • Born
  • Endorphin
  • Posts: 3

Post 3+ Months Ago

Hello there,

fisrt of all....i'm new here, so please be gentle...:)

ok, here's my problem:

i have a main movie, let's call it "mainmovie.swf"
then i have another movie called "loadinganim.swf"
and i have a movie called "interface.swf"

in "mainmovie.swf" i have two empty clips wich load "loadinganim.swf"
and "interface.swf". "interface.swf" has a preloader and a button.

when it is finished loading, i can see the button wich is in the movie called "interface.swf", but i can NOT click it anymore.

can anybody please help me out???

many, many thanx in advance!
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Endorphin
  • Born
  • Born
  • Endorphin
  • Posts: 3

Post 3+ Months Ago

:cry: nobody??
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13502
  • Loc: Florida

Post 3+ Months Ago

What are the actions for that button ?
It sounds like you have that buttons actions targeting somthing that has had it's path changed since the mC was loaded.

For instance, If the mC being loaded has that button inside an mC, & somthing else in it that the button references using _root, then it's looking for that inside the mC that it has just been loaded into.

here's a path example.
on the button in the movie being loaded,
Code: [ Select ]
on(press){
   _root.animation.play();
}
  1. on(press){
  2.    _root.animation.play();
  3. }

may need to be,
Code: [ Select ]
this._parent.animation.play();


If you can show us the actions for the offending button it would be much easier to help you pinpoint your problem.
  • Endorphin
  • Born
  • Born
  • Endorphin
  • Posts: 3

Post 3+ Months Ago

joebert

can i email the files to you? my PM don't work.... :cry:
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13502
  • Loc: Florida

Post 3+ Months Ago

Your PMs work, I just wasn't online when you sent it (online status is slightly delayed)

I sent you my address, I'll post back here with some answers once I take a look at it :)
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13502
  • Loc: Florida

Post 3+ Months Ago

loadMovieNum() is one of the things I don't understand, It likes to overwrite events. I'd have to re-write the loading of this thing to be of any help with it :(

Post Information

  • Total Posts in this topic: 6 posts
  • Users browsing this forum: No registered users and 11 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.