A sliding thumbnail gallery

  • pinkpoison
  • Born
  • Born
  • pinkpoison
  • Posts: 1

Post 3+ Months Ago

Hi everyone. Please if anyone can help wiith this one, I'd be super duper happy and thousands of hugs. Ok so I've seen many sliding thumbnail galleries before but I really like the one I saw on this site.

http://www.joshuadavis.com/pound.html

There's like a series of images and when a specific link is clicked, the gallery slides to that particular image. Its a little different from the normal sliding galleries that I've seen.

Please does anyone know how to do this? Or give me a link to someplace I can possibly learn it?

Thanks![/url]
  • lostinbeta
  • Guru
  • Guru
  • User avatar
  • Posts: 1402
  • Loc: Philadelphia, PA

Post 3+ Months Ago

The menu is basically http://www.kirupa.com/developer/flash5/slidingmenu.htm without the frame to hide the other boxes.

Sure probably a few other minor adjustments could be made, but the entire core theory of code is what is in that tutorial.
  • roarmeow
  • Professor
  • Professor
  • User avatar
  • Posts: 861
  • Loc: BKNY

Post 3+ Months Ago

http://www.layoutgalaxy.com/html/htmnew ... -page1.htm

it's a slightly different intention but the same mechanics of what you're looking for.
  • lostinbeta
  • Guru
  • Guru
  • User avatar
  • Posts: 1402
  • Loc: Philadelphia, PA

Post 3+ Months Ago

Warning with the above tutorial:

While it's a good exampe, setProperty and getProperty are actually Flash 4 slash syntax... Flash 5 and up adopted the new dot syntax which allowed you to access a clips property directly without going through a function. So something like
Code: [ Select ]
setProperty("clip1",_x,_root.imagewidth*1);
setProperty("clip1",_y,0);
  1. setProperty("clip1",_x,_root.imagewidth*1);
  2. setProperty("clip1",_y,0);
Would be written as
Code: [ Select ]
clip1._x = _root.imageWidth*1;
clip1._y = 0;
  1. clip1._x = _root.imageWidth*1;
  2. clip1._y = 0;


And
Code: [ Select ]
xpos = getProperty(_root.mainscroller.scroller,_x);
would be
Code: [ Select ]
xpos = _root.mainscroller.scroller._x;


Much cleaner and easier to read IMO. They have improved AS so much over the years.

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 10 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.