Help! weak sound after installing new sound card

  • gba_m
  • Student
  • Student
  • gba_m
  • Posts: 71

Post 3+ Months Ago

i had just installed hercules gamesurround fortissimo III. When I try to play a song, the sound that comes from my speakers is too weak and my volume is at max.

I updated to the current drivers and check at the control panel for audio.
The speakers are properly plugged in. I plugged them at the Front speakers channel. I tried plugging them to other channels but there is still no success.

Help!!!

Note: I used to have integrated audio
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • gba_m
  • Student
  • Student
  • gba_m
  • Posts: 71

Post 3+ Months Ago

never mind. i just found out that i need amplified speakers.
You can lock this topic now
  • whatlikesit12345
  • Guru
  • Guru
  • User avatar
  • Posts: 1211

Post 3+ Months Ago

no i think it may help other people down the road that come looking for a reason that there speakers may be quite.

this site does get a lot of traffic from google

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 63 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.