What happened to my PageRank?

  • UVBoy
  • Beginner
  • Beginner
  • User avatar
  • Posts: 50
  • Loc: London, Ontario, Canada

Post 3+ Months Ago

My homepage has always been PR 4, and I had many many internal pages of PR 3, 2, 1. I made some changes to how my site navigates and....poof!....no internal pages have a PR above zero. My URL's did not change a bit.

Before anybody jumps all over me about the apparent unimportance of PR, please realize that I've always used it as a measure of inbound link building campaigns. And while I understand that it's importance as a standalone measure is limited, it's still disconcerting to see any change to my website that is negative.

That home page PR must be going somewhere - does anybody know where it could have gone?

My website is aquatell (dot) com
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • The Leader
  • Novice
  • Novice
  • User avatar
  • Posts: 26
  • Loc: Melbourne Australia

Post 3+ Months Ago

The only internal page I can see with a pagerank is the /canada with a pr4, /hot-water-softener-works with a pr1. The rest are either na or pr0. Did all the other pages go offline for some reason, an adjustment to robots text?
  • Zealous
  • Guru
  • Guru
  • User avatar
  • Posts: 1244
  • Loc: Sydney

Post 3+ Months Ago

have you added a sitemap for the bots to find so they can understand the skeleton of the site better.
  • UVBoy
  • Beginner
  • Beginner
  • User avatar
  • Posts: 50
  • Loc: London, Ontario, Canada

Post 3+ Months Ago

Zealous wrote:
have you added a sitemap for the bots to find so they can understand the skeleton of the site better.


I sure have. Shortly after making the changes I created an XML sitemap that was (and is continuously) uploaded to Webmaster Tools.
  • Elia1234
  • Newbie
  • Newbie
  • Elia1234
  • Posts: 12

Post 3+ Months Ago

What kind of changes did you make? If by mistake you unfortunately damaged the robots.txt, then those certain pages may not be available for crawling anymore. It would be useful to check the directives you gave there.
  • Tophead
  • Born
  • Born
  • Tophead
  • Posts: 4

Post 3+ Months Ago

I heard people experiencing the same thing after making small changes. But that rarely happens. Their PR simply got back after Google re-indexed the website. Anyway, this might not be your case, as you said you have worked on navigation. I am pretty sure you messed up something, so you should re-check the work you did.

PS: I can see this is a quite old post, how is the situation now?
  • UVBoy
  • Beginner
  • Beginner
  • User avatar
  • Posts: 50
  • Loc: London, Ontario, Canada

Post 3+ Months Ago

Well, it took about 3 months, but my PR returned. All is good now with no changes by me.
  • maxgames
  • Born
  • Born
  • maxgames
  • Posts: 1

Post 3+ Months Ago

From what I see by placing your domain in Google search page is that either:
1. Your domain is banned since it doesn't appear even if you put the full url.
2. You've over used spam links to the domain using auto link building tools.
Which one of these makes sense to you?
  • TroubleShooter
  • Newbie
  • Newbie
  • User avatar
  • Posts: 12
  • Loc: Germany

Post 3+ Months Ago

And what about site's position in search engines? They are also fell down? If yes then your website got under one of Google's filters. If not then it's possible that PR falls is a temporary for your website.

Post Information

  • Total Posts in this topic: 9 posts
  • Users browsing this forum: No registered users and 1 guest
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.