I/O device error for external hard drive.

  • leashariff
  • Born
  • Born
  • leashariff
  • Posts: 1

Post 3+ Months Ago

Please help me.
I have 500GB external hard drive. Seagate brand.
It was all okay before. But suddenly, something pop ups
it says
"
G:\ is not accessible
The request could not be performed because of an I/O device error "

What should I do? I just bought it a few months ago. And everything is in there. All of my works are in there. Can I retrieve my files??
I am so worried. All of my works, artworks are all in there. My portfolios. What am I gonna do? Help me!

Is it my external hard drive or it's my laptop is not functioning well?
I plugged-in my external to another PC, but same thing appears.

I'm using HP Pavilion tx2500. Windows Vista.
Does these information help you to help me?
Pleaseee. help me.. :(
  • Don2007
  • Web Master
  • Web Master
  • Don2007
  • Posts: 4923
  • Loc: NY

Post 3+ Months Ago

If the same thing happens on more than one PC, then chances are your drive went bad. That's why all your data should be in more than one place. By now, everyone should know that.

Some people say, put it in the freezer overnight. Other things include:

Run chkdsk g: /f

mount it on a Unix box or boot with a Live CD.

Post Information

  • Total Posts in this topic: 2 posts
  • Users browsing this forum: No registered users and 10 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.