DVD drive not visible

  • alamode
  • Professor
  • Professor
  • User avatar
  • Posts: 927
  • Loc: Pakistan

Post 3+ Months Ago

I have a sony dvd rw drive and i had disabled it for some reason in the device manager so it had dissapeared. I also remember having enabled it back on and then it had appeared again but now it is not appearing. Cables are connected properly and everything but the drive isnt even showing up in the device manager either now.
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6375
  • Loc: twitter.com/unflux

Post 3+ Months Ago

Verify in disk management that the OS even sees the hardware. It very well could simply be that the device is using a duplicate drive letter. You can change that there.

Is it getting power?
  • alamode
  • Professor
  • Professor
  • User avatar
  • Posts: 927
  • Loc: Pakistan

Post 3+ Months Ago

Yep it was getting the power .. Anyway it suddenly starts appearing after reboot.
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6375
  • Loc: twitter.com/unflux

Post 3+ Months Ago

Ohhh...one of those "magical reboots" for windows. :lol:
  • alamode
  • Professor
  • Professor
  • User avatar
  • Posts: 927
  • Loc: Pakistan

Post 3+ Months Ago

How to access disk management ? Its invisible again.
  • alamode
  • Professor
  • Professor
  • User avatar
  • Posts: 927
  • Loc: Pakistan

Post 3+ Months Ago

Got it.
  • alamode
  • Professor
  • Professor
  • User avatar
  • Posts: 927
  • Loc: Pakistan

Post 3+ Months Ago

AAgh .. Actually its disappeared again and i dont see the drive in the Disk Management.

Actually the thing is that i have to sometimes disable my Dvd drive because i use Deamon tools and then i have to mount images to play a few games. So thats why i disable the drive. But right now i want to play a cd and its not picking up the drive.
  • deathblade
  • Proficient
  • Proficient
  • User avatar
  • Posts: 419
  • Loc: u.k

Post 3+ Months Ago

lol when mine wasn't showing up, i unplugged it booted then shut down, plugged it back in and booted then it was fine, that should make a differance but it does
  • alamode
  • Professor
  • Professor
  • User avatar
  • Posts: 927
  • Loc: Pakistan

Post 3+ Months Ago

Okey ill try that.
  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8416
  • Loc: USA

Post 3+ Months Ago

I bet you always have to restart when you re-enable the drive.
  • alamode
  • Professor
  • Professor
  • User avatar
  • Posts: 927
  • Loc: Pakistan

Post 3+ Months Ago

Yeah it started working now. I did what deathblade told me too.

BTW i restarted like 10 times and it still didnt show the drive. After i did what deathblade told me to, the drive still wasnt visible i had to go in the Device manager and enable it.

Post Information

  • Total Posts in this topic: 11 posts
  • Users browsing this forum: No registered users and 10 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.