external HD crash?

  • ozzyosb100
  • Graduate
  • Graduate
  • User avatar
  • Posts: 191
  • Loc: FL

Post 3+ Months Ago

I have a 250GB HD I use to store data on. I use it on my laptop and just a few minutes ago i went to pick up the laptop and drive and the power cord came loose, now the drive doesn't work. It shows up in my computer but i cant open it and it just sits there making slight noise as if it were reading.

If it helps I was defragmenting it, I had the defrag program (O&O defrag) open, I didn't see if it was done defragging but i assume so because its been running for over 9 hours, like i said i went to pick it up and the cord came loose.

any ideas on what i can do?

thanks
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • sezerb
  • Beginner
  • Beginner
  • sezerb
  • Posts: 64

Post 3+ Months Ago

The first thing I would do (if you haven't already done so) is re-start your computer and try it. If that doesn't work try it on another computer.
  • ozzyosb100
  • Graduate
  • Graduate
  • User avatar
  • Posts: 191
  • Loc: FL

Post 3+ Months Ago

i tried that it didnt work at first but now the scandisk program caught it and fixed it, thanks

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 38 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.