Laptop Turning off???

  • Luke1991
  • Born
  • Born
  • Luke1991
  • Posts: 3

Post 3+ Months Ago

hi, I have a Toshiba Satellite A70/A75 Series laptop.My laptop keeps shutting off.If i run alot of programs it shuts off and to turn it back on i need to wait about 5 min.I try to run spyware or adware and in the middle of the scan it shuts off.Also if i play a game in about 4 min. of the game the laptop shuts off.I heard it shuts off becouse it over heats and i need to change fans and clean the dust out but i dont think i can do that.
I just dont know what to do or get.I really need some info on how to fix this.Thnx
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • blink182av
  • Guru
  • Guru
  • blink182av
  • Posts: 1258
  • Loc: New York

Post 3+ Months Ago

how much RAM?
  • Luke1991
  • Born
  • Born
  • Luke1991
  • Posts: 3

Post 3+ Months Ago

how do u check
  • EliteHunter
  • Banned
  • Banned
  • User avatar
  • Posts: 409
  • Loc: Under Your Bed

Post 3+ Months Ago

LOL :lol: Right click the "My computer" Icon in your start menu or desktop
  • blink182av
  • Guru
  • Guru
  • blink182av
  • Posts: 1258
  • Loc: New York

Post 3+ Months Ago

EliteHunter -- forgot to say to go to "Properties" after right click "My Computer" -- In there you should see all of your system specifications; It would help if you posted all of them. If it has lack of RAM, which may in fact be the problem... but let's not go to far in pre-diagnosis.
  • Luke1991
  • Born
  • Born
  • Luke1991
  • Posts: 3

Post 3+ Months Ago

it has 448 MB of ram
  • Bgnn32
  • Banned
  • Banned
  • Bgnn32
  • Posts: 435
  • Loc: Western Mass

Post 3+ Months Ago

Toshiba had a problem with bad RAM chips in some of thier A70/75 series notebooks, do a quick search on thier site and you should be able to find info on it, if that is the problem they will replace it for free.
  • Axe
  • Genius
  • Genius
  • User avatar
  • Posts: 5739
  • Loc: Sub-level 28

Post 3+ Months Ago

if it's showing 448Meg of RAM, I'm guessing you've actually got 512Meg in there and it's just stealing 64Meg of it for video.

It may not be the RAM though.

Is there a fan in the laptop that works? You may be right, it could be getting overheated, and the fact that it doesn't turn on for a few minutes afterwards may be that it's just not cooled down enough for safe operation.

I've seen this with desktops countless times, and a couple of times in laptops.

Post Information

  • Total Posts in this topic: 8 posts
  • Users browsing this forum: No registered users and 44 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.