laptop went blank

  • associates
  • Student
  • Student
  • associates
  • Posts: 74

Post 3+ Months Ago

Hi,

I have a problem with my laptop. I let it be on for a while say approx 2 hrs or so. Everything was allright. I could get into windows and manage to surf the internet. But after a certain number of hours passed, i re-started the computer, the whole screen was blank. I mean it didn't even get to load up the windows.
It was blank the whole time right from the time i pushed the power on button.
There was no warning though.

My guess is the hard disk.

Can anyone suggest me to do? what could be the cause?

Thank you in advance
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • tomrulez
  • Expert
  • Expert
  • User avatar
  • Posts: 571
  • Loc: England!!

Post 3+ Months Ago

It could be the back-light in your monitor/display. Ive got an old laptop with the exact same problem and I really cant be botherd to fix such a small problem. If you get no display at all or cant see anything Id say it was your back-light.
  • Spyro
  • Novice
  • Novice
  • Spyro
  • Posts: 30

Post 3+ Months Ago

my guess is your laptop went into sleeping mode.
my laptop alway get into sleeping mode and when i restart it, i will get black screen, i hate it so much, so i just put a screen saver, and it's alright now.
  • GT500Shlby
  • Guru
  • Guru
  • User avatar
  • Posts: 1205
  • Loc: Philadelphia, PA

Post 3+ Months Ago

We really need more information. For instance when you power-on the machine does it actually power-on? Do you see a POST screen at least? Do lights and fans come on? Can you hear the hard-drive or CDrom spool up? Does it beep?

Try checking if the battery is well-seated and fully charged. Try taking out the battery for 60 seconds while unplugged from AC. Then put in the battery, plug in the AC power and try to power it on.

Some laptops have a function key to switch the monitor output to the VGA/DVI port on the bqack of the machine for external monitors and projectors. Make sure its not set to use an external monitor and that it just stut off the LCD.
  • libertycat
  • Born
  • Born
  • libertycat
  • Posts: 1

Post 3+ Months Ago

Hello,
I have the same : when want to go back from sleeping mode; I hear laptop waking up (fans cdrom and hd) but the screen is not switching on. this is really annoying really.
I dream to use the sleeping mode one day but I still never found the clue to correct this problem
I just heard somewhere that it can be problem from the network card.. but really I do not see how it could be...
If anybody can have clue, great thanks for taking time to drop several lines here
  • GT500Shlby
  • Guru
  • Guru
  • User avatar
  • Posts: 1205
  • Loc: Philadelphia, PA

Post 3+ Months Ago

I get that sometimes with older laptops. My parents have an old PIII IBM Thinkpad they keep in the kitchen. If that goes off on standby for whatever reason its hard to get back on without power cycling. You can hear it revive but the monitor stays down, no matter what you hit.

But, XP has the ability to do a clean shutdown when you do a soft power cycle from the button. So you wait a minute for it to clean shut down and then restart it and all is well.

I tried a bunch of the power settings, and I originally thought it was overheating, because it sits on a granite countertop that gets real hot from the laptop sitting on it. But mobo monitor 5 had all the temps in good ranges.
  • pani
  • Born
  • Born
  • pani
  • Posts: 1

Post 3+ Months Ago

Hi,

I have a similar problem. Whenever I shutdown my laptop and restart it after a couple of hours my laptop does not get powered on at all. I can see the power on led and no other activity/not even hard disk spinning sound, absolutely nothing happens. Only the power ON led will be glowing. Even the POST does not start, some times it takes almost 3-5 minutes to even start the POST. But once the POST is started and the system boots up withing 10-15 seconds and there is no problem after that.

I'm really not sure why this is happening, my guess is it could be taking time in identifying some hardware. But this does not happen every time I boot but only when there is a time gap between shutdown and restart (atleast 1 hour).

Any help in solving this would be great !

Thanks in advance

keep :)
pani
  • salim1001
  • Newbie
  • Newbie
  • salim1001
  • Posts: 5

Post 3+ Months Ago

Hi,

I know this is an old problem for some of you however did anyone get any solution for this cause since yesterday i have the same issue. The problem is that nothing appears on the screen even though i wait for a longtime.
The cooling fan keeps running and the Power ON and Hard drive light glows but other than this no Activity. Any help would be Appreciated.
  • Merlyn
  • Guru
  • Guru
  • User avatar
  • Posts: 1143
  • Loc: Oregon

Post 3+ Months Ago

A backlight issue?
  • grinch2171
  • Moderator
  • Genius
  • User avatar
  • Posts: 6805
  • Loc: Martinsburg, WV

Post 3+ Months Ago

salim1001 wrote:
Hi,

I know this is an old problem for some of you however did anyone get any solution for this cause since yesterday i have the same issue. The problem is that nothing appears on the screen even though i wait for a longtime.
The cooling fan keeps running and the Power ON and Hard drive light glows but other than this no Activity. Any help would be Appreciated.


Does the laptop beep when it powers on? The beeps are normal so you should hear them.
  • mentormatt8
  • Born
  • Born
  • mentormatt8
  • Posts: 1
  • Loc: USA

Post 3+ Months Ago

Oh, yeah, this is a good one. I found one weird solution that worked for me.

http://annoyances-resolved.blog spot dot com/2009/08/laptop-wont-resume-from-sleep.html

(just remove 3 blanks and fix dot)

You could also attach an external VGA monitor to further troubleshoot in case your screen went bad

Post Information

  • Total Posts in this topic: 11 posts
  • Users browsing this forum: No registered users and 29 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.