Please Help! Problem with my laptop!

  • mccurley0006
  • Born
  • Born
  • mccurley0006
  • Posts: 2

Post 3+ Months Ago

Last August I had my laptop (A Toshiba Satellite A105-S101) on but closed while making the bed and a cup of water fell and got onto the laptop. I didn't know what to do then and I turned it off, shook it out and then turned it on to see if it would work. It wouldn't go on at first, then would go on and off, and finally would work and still does. Here is my problem, the thing is in super slow motion. Everything on the computer goes slow. If I set the time on lets say Tuesday at noon then when I look at the time on Friday it will tell me its 12.25pm on Tuesday still. When I turn the computer all the way off the time goes normal though. I am an idiot and thought my Best Buy warranty was the only one I had (which was 30 days) and even though my computer was only 5 months old at the time I thought I was screwed and took it apart to try and fix it, so taking it back is out of the question!

I have been dealing with the slowness but just recently it has gotten super super slow (it took 1/2 an hour or more for anything to happen when I clicked on the start button). I noticed that when I tried to hold down the power key to restart it the computer started going at normal (not my slow normal but a real computer normal) speed, but unfortunately it turns off to restart (otherwise I would tape the dang thing down!). It also plays video and audio in slow motion.

When the whole water incident happened there was no smoke or noise coming from the laptop and after taking it apart a bunch of times I haven't found any signs of it getting fried. I did find some white residue in a small spot and I cleaned it off but it didn't make it any faster.

My question is, is there anything I can do to help the computer? I have also re-formatted the hard drive (a few weeks ago for a whole other reason) but it didn't do anything to help. I have been reading about cleaning the parts inside and was wondering what a good way to do that is. I figure now its a piece of junk so I may as well try to fix it myself, it isn't like I can do any more harm! I got the thing on a big sale where there was only like 3 in the store and I had to get in line to get it before they even opened (I paid only like $500) so it isn't worth it for me to pay the same amount on just a new hard drive or some other piece, I will probably do the same thing next month and buy a new one on sale if this doesn't work.

THANK YOU FOR ANY HELP!
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Don2007
  • Web Master
  • Web Master
  • Don2007
  • Posts: 4924
  • Loc: NY

Post 3+ Months Ago

It looks like you're going to have to have it serviced or attempt to open it and test it yourself.

Post Information

  • Total Posts in this topic: 2 posts
  • Users browsing this forum: No registered users and 28 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.