Toshiba Satellite 2455-S305 Sound Issue

  • devilwood
  • Silver Member
  • Silver Member
  • User avatar
  • Posts: 436

Post 3+ Months Ago

I'm reinstalling WinXP home on an old S305. I got all the devices installed except for the Multimedia Controller and another Unknown device both under OTHER in the device manager.

Windows update is no help. I've installed everything from Toshiba including a couple of common tools as well as updated the BIOS to 1.50. I repaired some A10/M10 Satellites that had Audio issues where an unknown device was showing along with an Unknown Audio/Multimedia device and an INTEL INF update ran before the SoundMAX audio installer fixed it, but the same didn't happen here. I've determined the Chipset is an INTEL 845E and the Unknown Device appears to be 82801 DB LPC Interface Controller (ICH4). I've updated the chipset from Intel's site and ran infinst_enu.exe, but it still won't find this device/controller. I've also tried Windows update again. It seems I've updated as much as I can. Is there a specific way I can get this Unknown device installed. I believe it's needed to install the Audio Driver cause when I run the SoundMax installer I get ERROR: Driver not found. Reboot and try again. (and that didn't work).

Thanks for any help if anyone else has had this issue.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Don2007
  • Web Master
  • Web Master
  • Don2007
  • Posts: 4924
  • Loc: NY

Post 3+ Months Ago

http://downloadcenter.intel.com/SearchR ... e+Edition*

The Intel driver should be there ^^.

http://download.cnet.com/Intel-Chipset- ... 62211.html

The unknown device driver should be there ^^.
  • devilwood
  • Silver Member
  • Silver Member
  • User avatar
  • Posts: 436

Post 3+ Months Ago

Thanks Don. I actually got those and tried them and didn't help. It seems these chipsets report to hardware ID programs that the 82801 Interface Controller is present and is the name of, I'm guessing, the part of the SouthBridge Bus. I do believe it's somehow linked to the onboard sound. Good news, however, is that I installed an old, old driver for the SoundCard and it fixed the missing soundcard issue, but I still have a missing driver for the 82801 Controller, but everything is working fine.. sound, video, network, alps.. etc. It's for an old couple and so I don't think they will run into any problems with that LPC controller missing. Foward, the A10 Toshiba I fixed needed the controller update and was recognized by Toshiba and reported that the intel chipset needed to be upgraded. I then re-did windows update and bingo. Once it was installed the sound driver would install. It didn't quite go the same on this S305. If anyone knows anything on this model then they can report here but I'm done messing with this one. It's really been a pain cause I don't like figuring stuff out.. especially drivers which I've been installing since 1996.
  • Don2007
  • Web Master
  • Web Master
  • Don2007
  • Posts: 4924
  • Loc: NY

Post 3+ Months Ago

I had an similar situation with a retired couple. The problem was the wireless driver so I installed a USB adapter, which worked fine until the lady did something stupid & killed the machine. I forget what it was. I convinced her to buy a new laptop since they are so cheap these days. I haven't heard from them since.
  • devilwood
  • Silver Member
  • Silver Member
  • User avatar
  • Posts: 436

Post 3+ Months Ago

Yeah, I think I've been behind that couple checking out at Office Depot. :-). Now, not talking about old people, but my step-mother bought her a new laptop and keeps having problems getting on the wireless network that I setup at my dad's house. She asks for me to look at it when I come over and it's the same thing every time. I say, "you've got to hit Fn +F2 to turn your wireless card on...Do you see the little antenna with the waves coming out?" I guess it wasn't any better on some laptops where the switch was on the front/side of the chassis. I wonder how many old people have that problems, talking about wireless specifically? Anyway, I doubt I'll hear from them, though, Toshiba dropped a point in my book for this and moreso that I've had the same issue with the mainboard sound on a different model.
  • Don2007
  • Web Master
  • Web Master
  • Don2007
  • Posts: 4924
  • Loc: NY

Post 3+ Months Ago

LOL Sometimes you have to take them by the hand as if they were children.

Post Information

  • Total Posts in this topic: 6 posts
  • Users browsing this forum: No registered users and 49 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.