usb not getting detected

  • david17
  • Proficient
  • Proficient
  • User avatar
  • Posts: 301
  • Loc: princeton, nj

Post 3+ Months Ago

hi everyone, i am having a problem with a usb device, it wouldn't work on a computer (it doesn't get recognized/detected-doesn't appear in "my computer") but if i try it on any other computer it would work.so i brought another flash drive which i plugged into the pc that primarily didn't recognize the other flash drive, the new usb would work fine. i tried several new usb drives on this computer but it's just that particular flash drive that doesn't work here, (it would work anywhere else).help please
david :)
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • benoitb
  • Graduate
  • Graduate
  • User avatar
  • Posts: 114
  • Loc: Washington, DC

Post 3+ Months Ago

When that happens to me I normally do a system restore or a reformat.
  • grinch2171
  • Moderator
  • Genius
  • User avatar
  • Posts: 6809
  • Loc: Martinsburg, WV

Post 3+ Months Ago

benoitb wrote:
When that happens to me I normally do a system restore or a reformat.


Holy crap :shock: One USB device having issues is no reason to format, that is a bit overkill.
  • blink182av
  • Guru
  • Guru
  • blink182av
  • Posts: 1258
  • Loc: New York

Post 3+ Months Ago

Nothing compared to my friend, He formats because a program does not open.
  • Brandon
  • Beginner
  • Beginner
  • Brandon
  • Posts: 50
  • Loc: Australia

Post 3+ Months Ago

maybe you need to install drivers for that usb device of yours.
  • think.correctly
  • Guru
  • Guru
  • User avatar
  • Posts: 1461
  • Loc: markham, ontario

Post 3+ Months Ago

maybe the drive letter that the computer would normally assign to a usb drive [e] is taken by something else.
  • david17
  • Proficient
  • Proficient
  • User avatar
  • Posts: 301
  • Loc: princeton, nj

Post 3+ Months Ago

i don't think the problem is the drive letter because when i put in another usb drive, it takes "e", but as brandon said maybe reinstalling the drivers for that drive might work , (eventhough it worked before and also xp should have the drivers for it), so i'll go to the website and reinstall it....i guess that's all what i have left..thank you all guys....
david :)
  • benoitb
  • Graduate
  • Graduate
  • User avatar
  • Posts: 114
  • Loc: Washington, DC

Post 3+ Months Ago

grinch2171 wrote:
benoitb wrote:
When that happens to me I normally do a system restore or a reformat.


Holy crap :shock: One USB device having issues is no reason to format, that is a bit overkill.


I try to fix it by replacing drivers if that fails, I resort to system restoe. When the system restore fails, I reformat. :-)

Post Information

  • Total Posts in this topic: 8 posts
  • Users browsing this forum: No registered users and 39 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.