'Could not connect to database'

  • morph
  • Novice
  • Novice
  • morph
  • Posts: 28
  • Loc: Kidderminster, England UK

Post 3+ Months Ago

I have been browsing through different forums to put on my site. However I came across PHPBB (this forum) and I though "yeah, thats a good forum". I installed it easily and I was configuring the admin control panel and forum management etc. Within 10 minutes a page loaded sayng 'Could not connect to database' and It wont let me goto my forums. However, it does sometimes let me into my forum but when pages load it occasionally comes up with the error. :( I love the PHPBB forums but my MySQL database seems to not connect.

I dont like forums which dont use databases either. :x

Anyone know how I can fix/help the problem? Ive already emailed my host but no reply yet.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9092
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Hmm that is a strange one. The only thing I can think of is maybe their MySQL on the server is having problems occassionally and that is when you cannot connect to it. It definetely sounds like something on their end though. I suggest turning on the debug feature in your PHPBB script so that it gives your more details about the error, other than "cannot connect". You might learn more about what is going on if you have the debug option on.
  • morph
  • Novice
  • Novice
  • morph
  • Posts: 28
  • Loc: Kidderminster, England UK

Post 3+ Months Ago

Yeah....thanx for the advice. I forgot about the error reports. I will probably have trouble doing that though. Cant even go into my admin cp sometimes because ofit. aarrgh :?
  • DiamondTiger
  • Beginner
  • Beginner
  • User avatar
  • Posts: 54
  • Loc: Podunk, Oklahoma

Post 3+ Months Ago

Posted: Tue Apr 04, 2006 12:02 pm Post subject: Could not connect to the database

--------------------------------------------------------------------------------

Hello there. Has anyone ever had this problem?

I asked my host last night, to change the password for my account, because some how the image files on one of my forum styles were replaced over night. My host changed my password, and I'm able to log in to my FTP and my cpanel... but, when I visit the url to my forum, I get the following error.

Warning: mysql_connect(): Access denied for user '******'@'localhost' (using password: YES) in /home/quincy/public_html/phpBB2/db/mysql4.php on line 48

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /home/quincy/public_html/phpBB2/db/mysql4.php on line 330

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home/quincy/public_html/phpBB2/db/mysql4.php on line 331
phpBB : Critical Error

Could not connect to the database


I'm not all that familiar with phpMyAdmin, so I'm not sure where I need to look to make sure that my db password was reset as well. I'm pretty sure that this is the problem. I'm a student, still learning how all of this stuff works, so if someone could please walk me through this and help me get my board back... I would very much be greatful. :) I'm kinda desprate to find a solution, because this is an operating forum with quite a few regular members. :?



----------------------------------------------------------

Nevermind guys... I fixed it. :oops: Thanks for reading my question tho. :mrgreen:

For anyone else who may run into this and freak like I just did... You gotta change your password in your config.php file too. ;)

Back to top

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 11 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.