cPanel / WebHost Manager (WHM) account setup

  • tdlbt
  • Newbie
  • Newbie
  • tdlbt
  • Posts: 9

Post 3+ Months Ago

Hi, quasi-neophite in over his head here...

I have just opened a dedicated server account that comes with cPanel and WHM pre-installed. I only plan to use it as a media file server with a few simple HTML pages linking to the media files.

I have registered a domain name, and pointed it to my host's name servers. The name servers are in turn setup to point that domain to my server's IP address.

Here's my question: How do I specify, in WHM, which directory on my server will be "hit" by a browser looking for http://www.mydomain.com, and what other settings, if any, do I need to tweak in order for this to work?

I could be wrong about this part, but I suspect that I have to "create an account" (in WHM) with a username, and that somehow, until the DNS info is resolved, I should be able to access it as http://my.si.te's.IP/~username/, right?

Problem is, when I try creating an account, WHM gives me the following error message:
Quote:
Please setup a nameserver under Server Setup in WHM!!!

Missing NS Config Line in /etc/wwwacct.conf

Account Creation Complete!!!


I have tried turning on the name server (in WHM), after assigning it my IP address, but I still would get the same error message when trying to create an account. Besides, why should I need to run my own name server if my host provides me with their own? I read on their (not very helpful) forums that a lot of people do not run their own name servers either.

Do I even need to be "creating an account" to begin with?

I have had sites on shared, "managed" servers before, so I have a limited understanding of how all of this works, but I need the bandwidth of a dedicated server, even though I'm using it for something that is technically very simple. Some "step-by-step" instructions would be great at this point, if someone feels up to it. But any input would be greatly appreciated.

Thanks!
  • tdlbt
  • Newbie
  • Newbie
  • tdlbt
  • Posts: 9

Post 3+ Months Ago

Ok, nevermind, I figured it out... :)

I didn't have any name servers defined in the "Edit Setup" section.
DUH! :roll:

I entered my hosting provider's name servers, and right away I was able to create an account.
  • thongtran
  • Born
  • Born
  • thongtran
  • Posts: 1

Post 3+ Months Ago

Hi tdlbt,

I know I'm responding to an old post, hopefully you still around or someone is still sround to help me with similar issue like your.

I have new server with cpanel all latest version. FreeBSD and CPanel.
So I got in the cpanel and thinking it's ready to go so I tried to add new account got the message you're getting above.

Quote:
Please setup a nameserver under Server Setup in WHM!!!
Missing NS Config Line in /etc/wwwacct.conf
Account Creation Complete!!!


I don't want to enable names server since I won't be using it, I just want to point a domain to this server host some files.

I disabled name server also. Where do I find the ""Edit Setup" section" like you said?

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 4 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.