ProFTPd won't display folder contents

  • camperjohn
  • Guru
  • Guru
  • User avatar
  • Posts: 1127
  • Loc: San Diego

Post 3+ Months Ago

I have installed ProFTP and have a problem that it won't display the contents of a folder. I can login fine.

I am connecting locally, from 192.168.0.101 (main machine) to 192.168.0.102 (server) so there shouldn't be a routing issue. But still no folders

I have been Googling for about 3 days hoping to find a solution to no avail. I need to figure this out before Saturday as that is when I am taking the server to the facility and don't want to upload 100 gigs of data through my cable modem - I need to do it directly.

Ideas?

Code: [ Select ]
[18:20:07] SmartFTP v2.0.996.28
[18:20:07] Resolving host name "192.168.0.102"
[18:20:07] Connecting to 192.168.0.102 Port: 21
[18:20:07] Connected to 192.168.0.102.
[18:20:07] 220 FTP Server ready.
[18:20:07] USER john
[18:20:07] 331 Password required for john
[18:20:07] PASS (hidden)
[18:20:07] 230 User john logged in
[18:20:07] SYST
[18:20:07] 215 UNIX Type: L8
[18:20:07] FEAT
[18:20:07] 211-Features:
[18:20:07] MDTM
[18:20:07] MFMT
[18:20:07] UTF8
[18:20:07] MFF modify;UNIX.group;UNIX.mode;
[18:20:07] MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
[18:20:07] REST STREAM
[18:20:07] LANG zh-TW;bg-BG;fr-FR;ko-KR;en-US;ru-RU;zh-CN;it-IT
[18:20:07] SIZE
[18:20:07] 211 End
[18:20:07] OPTS UTF8 ON
[18:20:07] 200 UTF8 set to on
[18:20:07] PWD
[18:20:07] 257 "/" is the current directory
[18:20:07] TYPE A
[18:20:07] 200 Type set to A
[18:20:07] PORT 192,168,0,100,226,151
[18:20:07] 200 PORT command successful
[18:20:07] MLSD
[18:20:07] 550 '/' cannot be listed
[18:20:07] Automatic failover of data connection mode from "Active Mode (PORT)" to "Passive Mode (PASV)".
[18:20:07] PASV
[18:20:07] 227 Entering Passive Mode (192,168,0,102,237,78).
[18:20:07] Opening data connection to 192.168.0.102 Port: 60750
[18:20:07] MLSD
[18:20:07] 550 '/' cannot be listed
  1. [18:20:07] SmartFTP v2.0.996.28
  2. [18:20:07] Resolving host name "192.168.0.102"
  3. [18:20:07] Connecting to 192.168.0.102 Port: 21
  4. [18:20:07] Connected to 192.168.0.102.
  5. [18:20:07] 220 FTP Server ready.
  6. [18:20:07] USER john
  7. [18:20:07] 331 Password required for john
  8. [18:20:07] PASS (hidden)
  9. [18:20:07] 230 User john logged in
  10. [18:20:07] SYST
  11. [18:20:07] 215 UNIX Type: L8
  12. [18:20:07] FEAT
  13. [18:20:07] 211-Features:
  14. [18:20:07] MDTM
  15. [18:20:07] MFMT
  16. [18:20:07] UTF8
  17. [18:20:07] MFF modify;UNIX.group;UNIX.mode;
  18. [18:20:07] MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
  19. [18:20:07] REST STREAM
  20. [18:20:07] LANG zh-TW;bg-BG;fr-FR;ko-KR;en-US;ru-RU;zh-CN;it-IT
  21. [18:20:07] SIZE
  22. [18:20:07] 211 End
  23. [18:20:07] OPTS UTF8 ON
  24. [18:20:07] 200 UTF8 set to on
  25. [18:20:07] PWD
  26. [18:20:07] 257 "/" is the current directory
  27. [18:20:07] TYPE A
  28. [18:20:07] 200 Type set to A
  29. [18:20:07] PORT 192,168,0,100,226,151
  30. [18:20:07] 200 PORT command successful
  31. [18:20:07] MLSD
  32. [18:20:07] 550 '/' cannot be listed
  33. [18:20:07] Automatic failover of data connection mode from "Active Mode (PORT)" to "Passive Mode (PASV)".
  34. [18:20:07] PASV
  35. [18:20:07] 227 Entering Passive Mode (192,168,0,102,237,78).
  36. [18:20:07] Opening data connection to 192.168.0.102 Port: 60750
  37. [18:20:07] MLSD
  38. [18:20:07] 550 '/' cannot be listed
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • SpooF
  • ٩๏̯͡๏۶
  • Bronze Member
  • User avatar
  • Posts: 3422
  • Loc: Richland, WA

Post 3+ Months Ago

Is there any reason you absolutely need FTP? I'm just wondering if you are going to be giving anyone else access to the server via FTP besides your self.

If you just need to transfer files you can use SFTP which transfers files via SSH. I hardly ever setup a FTP service on my servers because I just connect via SSH and do file transfer that way. It may be a quick fix for the time being if you can't get your FTP working.

I use FileZilla and just use the SFTP protocol and login via my SSH login information.

I'll look into the ProFTP thing thought too, SFTP is just a quick fix for you to start transferring your files.

One thing I'll quickly mention is that ProFTP will not allow symbolic links.
  • camperjohn
  • Guru
  • Guru
  • User avatar
  • Posts: 1127
  • Loc: San Diego

Post 3+ Months Ago

It will not only be for myself as I have a few clients that will upload files to their websites. But for now I have installed WinSCP on my computer to upload the bulk of the files.

The real deal is my editor uses FTP to do remote editing, and it's really easy to edit the site using this.

I am hoping it actually is a routing issue and that it will "go away" once I have it at the facility.
  • camperjohn
  • Guru
  • Guru
  • User avatar
  • Posts: 1127
  • Loc: San Diego

Post 3+ Months Ago

I am thinking it could be something to do with the user not having permissions. Remember, I did set up such that I login with 'john', not root, and the owner of the folder is 'john' also. Do I need to make john a member of the group ftp or ftpusers or something?

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 17 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.