4 GB on a 2GB USB

  • deathblade
  • Proficient
  • Proficient
  • User avatar
  • Posts: 419
  • Loc: u.k

Post 3+ Months Ago

I got a usb from college which has some how done a strange thing where it has more data on it the is physically possible, see I have a 2GB usb, see first image and shows as such in my computer, but if i open the drive and select all the folders it says I have 4.77 GB in the folders, see second image.

so now it says it is mounted as write protected and it refuses to format. I have tried formatting in CMD and still nothing and the USB doesn't even show when plugged into linux.

is this even fixable or is it time to get a new usb?
Attachments:
usb.png
Attachments:
usb2.png

usb data 2

  • a4asit
  • Kalkin
  • Graduate
  • User avatar
  • Posts: 114
  • Loc: India

Post 3+ Months Ago

hi

i think you found one of those unique usb drives that show wonders out of the box :D

i have seen such happen. i never saw it happen on windows though. there could be seceral reasons:

1. windows did not read your partition correctly. i guess either your usb port is defective or the driver. (wierd things happen. one of my usb ports works perfect with all my other devices but cranks with my 8GiB pendrive! and my pendrive runs perfect on other ports.. even on other's computers.. but doesnt seem to like THAT port!)
solution: check with other usb ports and/or reinstall windows drivers.

2. your pendrive is defective; maybe the socket is bent or cracked or the layer of circuit line has decayed by much use.
solution: check it several times on other's system; if useless get a new one ;)

3. your pendrive has been locked by mistake. there are several softwares that can actually lock partitions on drives. you cannot retrieve data even using a "raw" way! so linux can't "communicate" with your pendrive.
solution: just reformat it with FAT32 (and not FAT or NTFS). most os know it. FAT is also common.. but it sucks.. hehe

hope one of these work for you. reply if it worked.

regards
asit

Post Information

  • Total Posts in this topic: 2 posts
  • Users browsing this forum: No registered users and 37 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.