ftp invalid command

  • MSchienle
  • Born
  • Born
  • MSchienle
  • Posts: 3
  • Loc: Loveland, CO

Post 3+ Months Ago

I'm having a strange problem with one of my client's systems and an ftp command file. The clients have Win XP and Win 2000 systems, and I have a Win 2000 system, as well. The server runs MacOS X 10.2.8. I provided a simple dos script to copy files from their local systems to an ftp directory on the server. The script worked fine for the client with the Win XP system and my Win 2000 system, but not for the client with the Win 2000 system. The Win 2000 system having problems can run the commands successfully from the command prompt, but a dos batch file running the same commands generates "invalid command" command errors.

There is a bat file with three lines, that include the following ftp command:
ftp -in -s:ftp_cv.cmd

Here's the ftp_cv.cmd file:
open ftp.domain.com
user ftpuser ftppass
ascii
cd dirname
put file.txt
quit

The invalid command errors show up at the ascii line, but I can put in any command (cd, dir, etc.) there and it will generate the same error. What's really odd is that if the command is started without a batch file, it will work. In other words, typing:
ftp -in
followed by manually entering the contents of the ftp_cv.cmd file works just fine.

Any ideas would be greatly appreciated.

Post Information

  • Total Posts in this topic: 1 post
  • Users browsing this forum: No registered users and 51 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.