SOS I have lost all our rankings in just a few days !!!

  • acidburn
  • Born
  • Born
  • acidburn
  • Posts: 1

Post 3+ Months Ago

On March I uploaded one of my company's redesigned website, I did along with my IT team a new layout and changed our URL structure from TLDs to Subfolders based in languages and not countries as we used to have it.

We had I believe a minor problem which was having a javascript drop-down box for the language selection. We changed it to a CSS style combo. Still I havent figured out what exactly could have cause all our Google ranking to dissapear, in some cases even our trademarks are not showing our website and on April we did had very very good rankings for competitive keywords, this all started at the beginning of May.

Our website is for penis enlargement so be aware of the content, even when its a medical device maybe you feel uncomfortable opening it anywere.

Please Im desperate since I believe everything I have been doing on this site is well documented and I always try to follow SEO guidelines (robots.txt, sitemap, seo-friendly urls, internal links, image alts, metatags etc...)

I would appreciate if someone can help me identify if there is something that might have messed up, I dont want to think we have been banned or something, since we are still indexed and the sites page rank hasn't changed.

Post Information

  • Total Posts in this topic: 1 post
  • Users browsing this forum: No registered users and 7 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.