DirectoryIndex .htaccess

  • Trym
  • Born
  • Born
  • Trym
  • Posts: 4

Post 3+ Months Ago

My blog is at http://www.mydomain.com/weblog/

I make this show at http://www.mydomain.com by adding this line to the htaccess in my public directory:

DirectoryIndex /weblog/index.php

I have done this, but I can't access my other sides outside off the weblog.
I try to go to http://www.mydomain.com/photo and mydomain.com/media nothing happend?

her is my .htaccess

-----------------------
# -FrontPage-
DirectoryIndex /weblog/index.php
IndexIgnore .htaccess */.?* *~ *# */HEADER* */README* */_vti*


<Limit GET POST>

</Limit>
<Limit PUT DELETE>

</Limit>
AuthName http://www.mydomain.com
AuthUserFile /home/user/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/user/public_html/_vti_pvt/service.grp

--------------------------------------------------

someone help please?
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Axe
  • Genius
  • Genius
  • User avatar
  • Posts: 5739
  • Loc: Sub-level 28

Post 3+ Months Ago

Yeah, because when you enter /photo/, your server's trying to load /photo/weblog/index.php

Same for /media/...

Your best bet is setting up a 301 moved redirective in a PHP script on /index.php to forward it to /weblog/index.php - rather than using htaccess.
  • Trym
  • Born
  • Born
  • Trym
  • Posts: 4

Post 3+ Months Ago

Axe wrote:
Yeah, because when you enter /photo/, your server's trying to load /photo/weblog/index.php

Same for /media/...

Your best bet is setting up a 301 moved redirective in a PHP script on /index.php to forward it to /weblog/index.php - rather than using htaccess.



ok, that means my weblog cant be seen on http://www.mydomain.com?
  • Trym
  • Born
  • Born
  • Trym
  • Posts: 4

Post 3+ Months Ago

Axe wrote:
Yeah, because when you enter /photo/, your server's trying to load /photo/weblog/index.php

Same for /media/...

Your best bet is setting up a 301 moved redirective in a PHP script on /index.php to forward it to /weblog/index.php - rather than using htaccess.



My solution was to put all files from weblog in to public_html
and delete weblog.

And it works

Thanks to all helpers

:wink:

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 160 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.