$_GET issue

  • Nem
  • Guru
  • Guru
  • Nem
  • Posts: 1243
  • Loc: UK

Post 3+ Months Ago

Hi

Im having issues with $_GET request with php

When i do:

index.php?section=value

$_GET['section'] would return index.php

and if i was to do print_r($_GET)

i would get

$_GET ('section' => index.php);


any reasons why this is happening?
  • PolishHurricane
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1585

Post 3+ Months Ago

Unless you have some bogus server settings or your script is odd, then $_GET['section'] would most definitely be 'value'. I've seen some weird things happen with PHP taking in values before though.

Most likey it's an issue with your script, may I see it?
  • Nem
  • Guru
  • Guru
  • Nem
  • Posts: 1243
  • Loc: UK

Post 3+ Months Ago

sure, is it ok to pm you?
  • PolishHurricane
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1585

Post 3+ Months Ago

Yeah sure, not my bandwidth :P
  • Nem
  • Guru
  • Guru
  • Nem
  • Posts: 1243
  • Loc: UK

Post 3+ Months Ago

ok, i worked it out. it was my fault!! i had a stupid .htaccess file in the older, that was doing mod-rewrite.

lol

Post Information

  • Total Posts in this topic: 5 posts
  • Users browsing this forum: No registered users and 80 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.