Installed perl-debug, still get error with -D flag

  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13503
  • Loc: Florida

Post 3+ Months Ago

If you find yourself on a Ubuntu system, after having installed the perl-debug package like so,

BASH Code: [ Select ]
#sudo apt-get install perl-debug


and when you try to use perl with the -D flag it still tells you

Code: [ Select ]
Recompile perl with -DDEBUGGING to use -D switch (did you mean -d ?)


try using debugperl -D ... instead of perl -D ... or perldebug -D ...

BASH Code: [ Select ]
debugperl -Dr -e '/^([^.]+)$/'


I just spent about an hour tracking that down. Everything seemed to tell me I should use perl, or perdebug. Not the other way around like what actually worked for me. :)
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

Post Information

  • Total Posts in this topic: 1 post
  • Users browsing this forum: No registered users and 124 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.