WAMP server to connect to Oracle (oci)

  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

I'm looking for help in enabling connection of WAMP to Oracle. I tried almost all possible ways found on the internet but either it didn't work or still looking for a solution. Can anyone create a tutorial for this one or show the working steps ? I'm sure there's a way cause I saw someone already using it but have limited contact with that person and they just simply don't want to share out of selfishness.

Requirements:

    Windows 7 Home Premium x64 bits
    WAMP 2.0
    OCI driver (64 bits itanium / x64 bits edition) Windows not sure which one to use. We may get this from Oracle website. Couldn't download x64 bits edition the server was never up. Tried itanium 64 bits but couldn't get i working. Tried x32bits edition oci couldn't work as well.

  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • SpooF
  • ٩๏̯͡๏۶
  • Bronze Member
  • User avatar
  • Posts: 3422
  • Loc: Richland, WA

Post 3+ Months Ago

Check out this FAQ on oracle: http://wiki.oracle.com/page/PHP+Oracle+FAQ
  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

That won't help, SpooF. I went through that many times.
  • SpooF
  • ٩๏̯͡๏۶
  • Bronze Member
  • User avatar
  • Posts: 3422
  • Loc: Richland, WA

Post 3+ Months Ago

Then there is probably something wrong with your installation/network. That guide tells you how to connect to an Oracle server. A guide/tutorial probably wont help you. Where is the Oracle server hosted?
  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8399
  • Loc: USA

Post 3+ Months Ago

I'll just put a little link farm to check if you seeing these pages. Don't know anything about Oracle myself so I question my rational in making this post...

http://php.net/manual/en/oci8.installation.php
http://www.oracle.com/technetwork/articles/technote-php-instant-084410.html
  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

The problem is with x64 bits edition of Windows. I had connected successfully with 32-bits Windows.

There is no solution posted for this on the internet. I've searched many times on 3 different search engines.
  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

It is hosted locally: http://localhost/XE
  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

May I ask if anyone uses x64 bits windows ? Maybe we could research on this and fix this up.

My desktop is a 32 bits and it works fine.

I'm trying to get it work on my 64 bits.
  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

That's the problem with Moore's Law -- the software is not able to catch up with his Law !

Software = Amdahl's Law

It's time the programmers should start to learn parallel programming.
  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

It will also work on Windows come with the machine in x32 bits edition formally and upgraded to x64 bits.

It doesn't work on machine with factory x64bits...
  • SpooF
  • ٩๏̯͡๏۶
  • Bronze Member
  • User avatar
  • Posts: 3422
  • Loc: Richland, WA

Post 3+ Months Ago

Are you getting any sort of errors, and is error reporting enabled?
  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

SpooF wrote:
Are you getting any sort of errors, and is error reporting enabled?


Yes and yes.
  • SpooF
  • ٩๏̯͡๏۶
  • Bronze Member
  • User avatar
  • Posts: 3422
  • Loc: Richland, WA

Post 3+ Months Ago

What are the errors? Those are really help fully.
  • George L.
  • Bronze Member
  • Bronze Member
  • George L.
  • Posts: 2209
  • Loc: Malaysia

Post 3+ Months Ago

Hi SpooF, can't remember right now, it is not even PHP error, there are multiple errors. Prior to getting PHP web based error the web server couldn't start at all. That looks more like pop up PHP/VB/Java error stating that the driver either not compatible or couldn't locate any. Sometimes we can't even get the web server up and running.

Sorry I couldn't get back as soon as I can with this because this I predict to be a lot of work. I'm with other stuff because I only need to compare some scripts I used--only if I could get oci connected. Else, I can just continue without referring to the additional (scripts)notes.

.. I'm doing my project by the way ..
  • balmydrizzle
  • Born
  • Born
  • balmydrizzle
  • Posts: 1

Post 3+ Months Ago

Though this might be late but I'm using appserv v2.5.10 + win7 64bit. I do cheat system and php and also other win32 oracle client app (e.g. Toad) and make them connect to Oracle8i successfully. In my old Winxp,I've installed Oracle9i client. I copy c:\ora9ias from old winxp to same location to win7 pc. and make a c:\oradll and copy all *.dll to c:\oradll and then put both path into PATH environment with c:\oradll at the last one (note: I uses depends22_x86 tool to test all relevant dll for accessing Oracle8i to see what dependent dlls it fails to access and then copy those dlls from winxp PC to win7 PC). I guess if when loading any oracle-relevant lib or dll, it could try to find dependent dll from the PATH environment and also manually edit wowx64 registry for win32 dll or library. At last, I can use OCI8 to access Oracle8 from PHP and run Toad to access Oracle8, too. My current PHP can access mysql, Oracle8(via builtin oci8) and older MSSQL (via builtin MSSQL lib) and finally newer MSSQL, e.g. SQL Server 2008(via sqlsrv from M$). Actually, I still didn't figure out how Oracle8i access is done succesfully but if anyone has this need and would like to have a try of my way. You can contact me with email via balmydrizzle at gmail . com (I can never do it ok with WAMPServer)

Post Information

  • Total Posts in this topic: 15 posts
  • Users browsing this forum: No registered users and 122 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.