Windows Media

  • bluedragon
  • Proficient
  • Proficient
  • bluedragon
  • Posts: 452

Post 3+ Months Ago

Ok I did a search here and couldnt find it. All I need to know is the code for playing music on my website. For Windows Media.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • bluedragon
  • Proficient
  • Proficient
  • bluedragon
  • Posts: 452

Post 3+ Months Ago

http://www.ntcssforums.tk is where I want it to be played but I cant get it to work.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

What I see in your code is this:
Code: [ Select ]
<embed src="http://all4actions.com/~ntcss/music/Linkin%20Park-Numb.mp3">


It should be this:
Code: [ Select ]
<embed src="http://all4actions.com/~ntcss/music/Linkin%20Park-Numb.mp3">


The former causes the browser to parse your code as text - which is why the song doesn't play.

The latter embeds the code and causes Windows media player (or whatever media player the user has set as default for MP3's to play the song).

The problem is that I can't tell if you wrote it that way, or the php is parsing the HTML that way.

Hope that helps.
  • bluedragon
  • Proficient
  • Proficient
  • bluedragon
  • Posts: 452

Post 3+ Months Ago

Ok that worked and one more question. When i go to add a new block on my site it starts to load a page then it goes to a blank page and says Done. What should I do?
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

Sorry - that I can't answer. I have no experience with phpnuke. Others here do, however. So I'm sure you'll get an answer. To help, I'm going to move this to our programming board. PHP coders hang out there more than here.
  • bluedragon
  • Proficient
  • Proficient
  • bluedragon
  • Posts: 452

Post 3+ Months Ago

Ok thanks. And has anyone heard of this file and has anyone ever used it:

http://www.all4actions.com/~ntcss/files/WMP-html.zip
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

As a side note, I see the code changed to what I suggested when I refreshed the page, but it is not playing the music for me. Still displays text, albeit the correct text.

Must be something with the way php is interpreting it. You should get an answer or two here. Good luck.
  • _Leo_
  • Proficient
  • Proficient
  • User avatar
  • Posts: 279
  • Loc: Buenos Aires, Argentina

Post 3+ Months Ago

Ok, It's quite simple. You have to build an HTML file and include an ActiveX object, in this case the Windows Media Player ActiveX Plugin

Code: [ Select ]
<OBJECT ID="DSPlay1" WIDTH=300 HEIGHT=25 classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
    codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701"
    standby="Loading Microsoft Windows Media Player components..."
    type="application/x-oleobject">
  <PARAM NAME="FileName" VALUE="mms://server-ip/file.wma">
    <PARAM NAME="AnimationAtStart" VALUE="0">
  <PARAM NAME="ShowControls" VALUE="0">
  <PARAM NAME="ShowDisplay" VALUE="0">
  <PARAM NAME="ShowStatusBar" VALUE="1">
  <PARAM NAME="AutoSize" VALUE="1">
  <PARAM NAME="Volume" VALUE="200">
  <Embed type="application/x-mplayer2"
    pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/Products/MediaPlayer/"
    FileName="mms://server-ip/file.wma"
    Name=DSPlay1
    ShowControls=0
    ShowDisplay=0
    ShowStatusBar=1
        Volume=200
    width=300
    height=25>
  </Embed>
</OBJECT>
  1. <OBJECT ID="DSPlay1" WIDTH=300 HEIGHT=25 classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
  2.     codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701"
  3.     standby="Loading Microsoft Windows Media Player components..."
  4.     type="application/x-oleobject">
  5.   <PARAM NAME="FileName" VALUE="mms://server-ip/file.wma">
  6.     <PARAM NAME="AnimationAtStart" VALUE="0">
  7.   <PARAM NAME="ShowControls" VALUE="0">
  8.   <PARAM NAME="ShowDisplay" VALUE="0">
  9.   <PARAM NAME="ShowStatusBar" VALUE="1">
  10.   <PARAM NAME="AutoSize" VALUE="1">
  11.   <PARAM NAME="Volume" VALUE="200">
  12.   <Embed type="application/x-mplayer2"
  13.     pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/Products/MediaPlayer/"
  14.     FileName="mms://server-ip/file.wma"
  15.     Name=DSPlay1
  16.     ShowControls=0
  17.     ShowDisplay=0
  18.     ShowStatusBar=1
  19.         Volume=200
  20.     width=300
  21.     height=25>
  22.   </Embed>
  23. </OBJECT>


Note that all parameters are duplicated. This is needed for the plug-in working on non-IE browsers like Netscape. Check also the FileName parameters as it is the actual file or station you want to play. Note the mms:// protocol is intended for Windows Media Servers. It won't work if your WMA file is hosted on the web. In such case, you should use http://server-name/file.wma
  • bluedragon
  • Proficient
  • Proficient
  • bluedragon
  • Posts: 452

Post 3+ Months Ago

ok I dont really understand most of that but I'm trying. The link where my file is is: http://www.all4actions.com/~ntcss/music ... k-Numb.mp3 How would I put that into PostPHP? For somereason I cannot make a new block which is really making me mad cause I have to re-add my shoubox since I accidentally removed it. If you can help please please help me. I'm lost.
  • bluedragon
  • Proficient
  • Proficient
  • bluedragon
  • Posts: 452

Post 3+ Months Ago

Do I have to use wma files cause still at my website its messing up.
  • _Leo_
  • Proficient
  • Proficient
  • User avatar
  • Posts: 279
  • Loc: Buenos Aires, Argentina

Post 3+ Months Ago

No, I haven't tried WMP Plug-in with MP3 files but I think it should work fine. I would recommend you starting by making a simple HTML file with the code I have passed inside it. Once you get it working, try to pass it to a CMS.

I don't know about PostPHP, but most CMS have some way for adding HTML files to the site. If you are trying to insert that code with a control panel, you have to be sure the panel is not messing up the HTML code. <OBJECT> and <EMBED> tags are HTML but not usually used, therefore, it is possible for a CMS to ignore these and break the embed code (the code I posted before)

Post Information

  • Total Posts in this topic: 11 posts
  • Users browsing this forum: No registered users and 84 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.