Comment: User details column

  • lioness
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1615

Post 3+ Months Ago

Is it just me or is the gray bar below my username in viewing a topic right-aligned? I see everyone elses as left-aligned - is this normal for the rest of you? I just noticed it recently... :?

For my posts I see <username> <gray bar> (right-aligned) <user title>

For everyone eelse I see <username> <user title> <gray bar> (left-aligned)
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13502
  • Loc: Florida

Post 3+ Months Ago

I bet it has somthing to do with "Guru" being a short title.

I looked at the memberlist (Sort By "Total Posts, DESC"), lostinbeta is also a Guru & his is doing the same thing.

//Edit - So is Foxy, also a Guru.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

It's a problem with the smartDark viewtopic_body.tpl. If you view source there's no break tab between the rank title and the image for the rank. So it's wrapping wrong. This should be a 5 second fix.
  • lioness
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1615

Post 3+ Months Ago

ATNO/TW wrote:
It's a problem with the smartDark viewtopic_body.tpl. If you view source there's no break tab between the rank title and the image for the rank. So it's wrapping wrong. This should be a 5 second fix.


Yeah I viewed the source and saw nothing in there that would have been casuing it.

joebert wrote:
I bet it has somthing to do with "Guru" being a short title.


You bet right my friend - good spot.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

Well, I said the same thing, but the cause of the problem is exactly what I said.

Even though the rank image appears small it's actually 25 pixels high. Approximately 20 pixels of the height are transparent. Normally the longer rank titles cause the image to wrap naturally to the next line so the rank title appears above the rank image. Titles of four characters or less do not force this natural wrapping, thus leaving both the title and image on the same line. Although the word guru appears to be below the rank image it's actually not. It's immediately to the left of the image. You can test my point by right clicking the empty grey area immediately under the image and just to the right of the word guru and you'll see you have the options normal to view and save images.

As I stated the problem is because of a missing break tag in the viewtopic_body.tpl file of the smart dark theme. The HTML produced by the code is (see orange highlight):

<td width="150" align="left" valign="top" class="row1"><span class="name"><a name="350839"></a><b>ulstermonkey</b></span><br /><span class="postdetails">Guru<img src="images/ranks/greybar/rank9.gif" alt="Guru" title="Guru"><br /><img src="images/avatars/107535228244b50faeb63d8.jpg" alt="" border="0" /><br /><br />Joined: 23 Jun 2004<br />Location: Boston<br /><br />Status: <span style="font-weight:bold; color:#008500">Online</span><br />Posts: 1370</span><br /></td>

It should be:
<td width="150" align="left" valign="top" class="row1"><span class="name"><a name="350839"></a><b>ulstermonkey</b></span><br /><span class="postdetails">Guru<br /><img src="images/ranks/greybar/rank9.gif" alt="Guru" title="Guru"><br /><img src="images/avatars/107535228244b50faeb63d8.jpg" alt="" border="0" /><br /><br />Joined: 23 Jun 2004<br />Location: Boston<br /><br />Status: <span style="font-weight:bold; color:#008500">Online</span><br />Posts: 1370</span><br /></td>
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9089
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

I fixed the problem without adding a break tag. I wonder who can figure out what I did first.
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13502
  • Loc: Florida

Post 3+ Months Ago

Set the display of .postdetails img to block ?

Aren't img elements naturally floated ?

display:block;
clear:both;

? :D
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

Yeah that's what he did. It used to be just

.postdetails { font-size : 10px; color : #CCCCCC; }

Now it is

.postdetails { font-size : 10px; color : #CCCCCC; }

.postdetails img {
display:block;
margin:0px;
padding:0px;
}
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13502
  • Loc: Florida

Post 3+ Months Ago

Then again, doesn't clear only apply to other floated elements ? :scratchhead: I forget theese things.
  • SpooF
  • ٩๏̯͡๏۶
  • Bronze Member
  • User avatar
  • Posts: 3422
  • Loc: Richland, WA

Post 3+ Months Ago

Are you sure its fixed?

Image
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

refresh the page and/or clear cache (It's using a cached copy of the style sheet)
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9089
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

joebert wrote:
Then again, doesn't clear only apply to other floated elements ? :scratchhead: I forget theese things.


Yes that would only apply to floated elements.

And Spoof, like ATNO said it sounds like you need to clear your cache.
  • lioness
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1615

Post 3+ Months Ago

Ah it's fixed (I had to F5 refresh) - thanks Bigwebmaster. I now feel part of the gang again :)
  • SB
  • Moderator
  • Genius
  • User avatar
  • Posts: 8742
  • Loc: Aberdeen, Scotland

Post 3+ Months Ago

No big deal or anything, but i am assuming because you have done that to the code BigWeb this might be the reason the forums now look like this...

Image

They appear spaced out i assume because the "visit last post" button is now under the username instead of it being alongside like it was before.
  • lioness
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1615

Post 3+ Months Ago

SB wrote:
No big deal or anything, but i am assuming because you have done that to the code BigWeb this might be the reason the forums now look like this...

Image

They appear spaced out i assume because the "visit last post" button is now under the username instead of it being alongside like it was before.


I saw that, but didn't make the connection. That's probably right SB
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9089
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Good find, I will look into it.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9089
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Fixed, if you notice anything else let me know.

Post Information

  • Total Posts in this topic: 17 posts
  • Users browsing this forum: No registered users and 3 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.