tabbed browsing @ ozzu

  • Rascob
  • Novice
  • Novice
  • Rascob
  • Posts: 31

Post 3+ Months Ago

I don't know if this is supposed to be a problem, or if the problem appears just on me. I browse the ozzu forum with Mozilla Firefox 0.8 and and there seems to be a malfunction(?) when opening threads in new tabs with ctrl+click. So, (just in links like those on threads, you know, which on mouse over the cell's backround color changes) when i ctrl+click(pressing ctrl opens the page in a new tab) a thread it opens a new tab, as it should, but it loads the thread in the current page as well.

Sorry if it has been mentioned before but I searched a bit and found nothing relevant.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • rtm223
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1855
  • Loc: Uk

Post 3+ Months Ago

works fine with my Firefox 0.8 I think it is a problem at your end, there is no way to control tabbed browsing from the server side, so I guess you got a firefox bug.

Try a re-install, should only take 10 mins. :)
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6376
  • Loc: twitter.com/unflux

Post 3+ Months Ago

yeah i have FF installed and don't see what you see either. Probably a bug as rtm suggests.
  • Rascob
  • Novice
  • Novice
  • Rascob
  • Posts: 31

Post 3+ Months Ago

hmmm weird... anyway, I'll try redownloading
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

No Rascob has it exactly correct.

Reading what he said about the links where the background changes onmouseOver he's talking about the main forum page and the individual topics pages.


If you open Ozzu in Firefox and CTRL + click the General Forum Link, the General forum will open in a new tab, but will also change to the general board in the original tab.

Now CTRL + click any topic in the General board (either tab) and it will open the thread in a new tab, but also reload the original tab to the new topic as well.

I have no clue what the cause is, but I see exactly what he's saying.
  • rtm223
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1855
  • Loc: Uk

Post 3+ Months Ago

Uh, having read atno's post and testing, I would be willing to put money on the fact that we have onclick event handlers on the table cells.

If you click <b>just</b> on the table cells (away from the links) you trigger the js loading into the same page. The ctrl for tabbed browsing only seems to work with html links.

Now if you click on the link, you trigger both the link and the onclick event handler. The html link will load into a new tab, because you are holding the ctrl key, but the link is a part of the cell, so you are still clicking on the cell and triggering the javascript.

Ho hum, I think me and unflux didn't read the post properly.....

Well, sorry for wasting our time rascob, it wasn't just you after all.

Post Information

  • Total Posts in this topic: 6 posts
  • Users browsing this forum: No registered users and 2 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.