Cannot find my wireless card.

  • daiondoroga
  • Newbie
  • Newbie
  • daiondoroga
  • Posts: 10

Post 3+ Months Ago

Hey guys. I had everything working in PCLinuxOS, and had samba working and everything. It was fantastic. Then I read that I should install "madwifi" drivers for my wireless card (based on atheros chip). Everything was fine after the install, and I went about my merry business. Then I logged into windows to play a game for a while...

When I finished playing and wanted to boot into PCLinuxOS, during the bootstrapping process, the system would hang when trying to load ath0, giving the error:

"Kernel panic - unable to ..(forgot): fmedia_set"

So, I googled this, and found that it was an error related to the madwifi driver. So, after choosing NOT to load ath0 on bootstrap, I was back in linux. I opened my package manager, found madwifi driver, uninstalled. Restarted. This time, during the bootstrap, there was no hang, but ath0 failed to load, reporting that it could not find a suitable device or something.

On into linux, I opened harddrake, tried to load the ath_pci driver that came with the distro, but an error pops up: "Unable to find wireless device." The same behavior is exhibited in the wlanassistant program when I run it --> "No usable wireless device!"

After seeing this, I decided to open /etc/modprobe.conf and comment the ath0 line. I shut down, opened my case, and physically removed the card. I then restarted, ath0 interface loaded, linux came right up. I thought all was well. I uncommented the ath0 line in /etc/modprobe.conf, saved, then shut down and replaced the card. Upon rebooting however, ath0 interface failed to load again, and I see the same behavior described above when trying to configure the module...

Given my very limited experience, I'm completely out of ideas. Does anyone know how to correct this problem, or maybe have any ideas?

Should you need my lsmod or lspci, let me know.

Thanks
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • AnarchY SI
  • Web Master
  • Web Master
  • User avatar
  • Posts: 2521
  • Loc: /usr/src/MI

Post 3+ Months Ago

well it would definitely be good to know if lspci see's the wireless card. ;)
have you tried reinstalling the atheros drivers? like, a newer / more updated version from servers online? if there is one..


as a very last resort, you could always reinstall...but that just sux to have to do.
  • Enjoi_Panda_Man
  • Graduate
  • Graduate
  • Enjoi_Panda_Man
  • Posts: 166
  • Loc: TX

Post 3+ Months Ago

well you could perhaps use ndiswrapper and have it utilize the windows drivers for that card.

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 56 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.