so close to have my pcmcia NIC working

  • sonylloyd
  • Born
  • Born
  • sonylloyd
  • Posts: 3

Post 3+ Months Ago

My pcmcia network card is ready to be set with "ifconfig"
(at this point, "ifconfig" gives nothing apart the loopback
interface)..as you can see in the details below.
Problem is that there's no I/O nor IRQ available for the NIC!

->here are the details:

I did plug a linksys pcmcia ethernet card to my laptop,
did boot linux Mandrake 7.0 -> at linux boot up, I can
see "cardmgr" has detected the Linksys Etherfast network card (with no mention of irq, nor I/O).
->/sbin/cardctl status and /sbin/cardctl ident
both detect the card:
# /sbin/cardctl
socket 1:
5V 16-bit pc card
function 0: [ready],[wp]
But does not give m eany I/O and IRQ!!!!
# /sbin/cardctl ident
Socket 1:
Product info: "Linksys", "Etherfast 10/100 Integrated PC Card (PCM100), "Ver 1.0"
manfid: 0x0149, 0xc1ab
function: 6 (network)
Is the MANFID the I/O??? What about the IRQ?
How come the IRQ and I/O are not displayed?
Actually, even with "LSPCI -V", I do not get any "I/O,IRQ for my network card!
Same thing for "cat /proc/ioports" and "cat /proc/interrupts".
All available IRQs and I/O are already taken by other devices.
More details that tells me that I am so close to have
the pcmcia working ->
->when I run "lsmod" , I get:
pcmcia_core (used by ds i82365)
i82365 (used by 2) ..that's the module for my nic right?
->card services are running cause
when I run " ps -ef | grep cardmgr ", I get:
root 746 1 9 19:05 /sbin/cardmgr
->In /etc/sysconfig/pcmcia, I have:
PCMCIA=yes
PCIC=i82365
BUT IN /etc/pcmcia/config, there's no exact entry
for my nic (such as it was outputted by "/sbin/cardctl ident"). Most of them are linksys e-cards, except for
the following one:
->card "Linksys Ethernet"
version "Linksys", "Combo PCMCIA Ethernet Card (EC2T)"
bind "pcnet_cs"
Actually there's an entry that caught my attention
cause it has same "MANFID" as the "CARDCTL IDENT" outputs on my system:
->card "NE2000 Compatible Ethernet"
version "Ethernet", "Adapter"
#manfid 0x0149, 0xc1ab
bind "pcnet_cs"
(What's the point of /etc/pcmcia/config? What do I need to do here? should I rely on the ne2000 entry or should I absolutely add or rely on the linksys entries. If I should rely on the ne2000 entry, should I take out the # symbol in front of manfid 0x0149, 0xc1ab ?? ??????)

I checked all I/O and IRQs with "cat /proc/interrupts" and "cat /proc/ioports"
and all of them are already taken by other devices.
The Pcmcia network card is a Linksys Etherfast 10/100 Integrated PC Card v.2".
Also: At linux bootup, as soon as the card services
are loaded, I see my NIC leds lighting up..so I guess I am just at one step of having it working.
I guess I just have to "ifconfig" the NIC card, but
how am I going to do it without any IRQ and I/O for it.


Linux Mandrake 7.0
Kernel 2.4.8
nic: linksys pcmcia etherfast 10/100 pc card (pcm100 v2)
  • phpSelectah
  • Student
  • Student
  • User avatar
  • Posts: 97

Post 3+ Months Ago

your pcmcia card should have the same irq as your pcmcia bus.

it doesn't get special irq at boot, becasue it is a psuedo hot swappable device and is allocated memory / resources whenever it is inserted dynamically.

Since the LED is on, you know you are close. ;)


google that stuff, mang !


good luck :P
  • sonylloyd
  • Born
  • Born
  • sonylloyd
  • Posts: 3

Post 3+ Months Ago

True, it should get the irq and i/o of the pcmcia bus.
But none of the irq + I/O available are assigned to
the pcmcia bus.

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 67 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.