Have a problem with mysql installing on Cent os

  • Rajics
  • Born
  • Born
  • Rajics
  • Posts: 2

Post 3+ Months Ago

Hi

I have installed the mysql on my box with the help of link http://lamphowto.com/ and am not able to do the below step
cd /usr/local/src/mysql-4.1.22
./configure \
--prefix=/usr/local/mysql \
--localstatedir=/usr/local/mysql/data \
--disable-maintainer-mode \
--with-mysqld-user=mysql \
--with-unix-socket-path=/tmp/mysql.sock \
--without-comment \
--without-debug \
--without-bench and its showing
the error like NOTE: This is a MySQL binary distribution. It's ready to run, you don't
need to configure it!

To help you a bit, I am now going to create the needed MySQL databases
and start the MySQL server for you. If you run into any trouble, please
consult the MySQL manual, that you can find in the Docs directory.

./scripts/mysql_install_db: line 115: ./bin/my_print_defaults: cannot execute binary file
Neither host 'server.aol.com' nor 'localhost' could be looked up with
./bin/resolveip
Please configure the 'hostname' command to return a correct
hostname.
If you want to solve this at a later stage, restart this script
with the --force option

and try to run the following cmds
/etc/rc.d/init.d/mysql start
/etc/rc.d/init.d/mysql stop

its throwing error

etc/init.d/mysql: line 237: ./bin/my_print_defaults: cannot execute binary file
/etc/init.d/mysql: line 240: ./bin/my_print_defaults: cannot execute binary file
MySQL manager or server PID file could not be found! [FAILED]
/etc/init.d/mysql: line 237: ./bin/my_print_defaults: cannot execute binary file
/etc/init.d/mysql: line 240: ./bin/my_print_defaults: cannot execute binary file
Starting MySQL/etc/init.d/mysql: line 159: kill: (6485) - No such process
[FAILED]

as am doing it for first time not able to find out what the error is.... can anyone help me how to resolve this. and am planning to setup my local machine with apache,tomcat,mysql and perl and make it as website. please help me how to do this.

Thanks
Raji
  • Don2007
  • Web Master
  • Web Master
  • Don2007
  • Posts: 4923
  • Loc: NY

Post 3+ Months Ago

What OS are you running? Is the machine connected to the net?

Neither host 'server.aol.com' nor 'localhost' could be looked up with ./bin/resolveip

That error shows that either there is config file &/or a hosts that has to be edited. Where did it get server.aol.com?
  • Rajics
  • Born
  • Born
  • Rajics
  • Posts: 2

Post 3+ Months Ago

I have set the hostname as server.aol.com at /etc/hosts and now everything is fine.. but the problem is am not able to make my browser up. when i hit my browser with ip.. Its not loading i have installed the package with the help of following url http://www.mysql-apache-php.com/centos-lamp-server.htm
  • Don2007
  • Web Master
  • Web Master
  • Don2007
  • Posts: 4923
  • Loc: NY

Post 3+ Months Ago

What do you mean by "make my browser up" & "when i hit my browser with ip"?

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 8 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.