mandriva help

  • psuedofy
  • Expert
  • Expert
  • User avatar
  • Posts: 749
  • Loc: long island, NY

Post 3+ Months Ago

About two or three days ago i was updating my mandriva distro, i believe the icon said it was mandriva 9.0

after i updated, everything runs fine up until the login screen. either i cant remember my password, which i doubt because my passwords are never forgotten and are usually 3 words i circulate through whatever requires a password.

i click guest, i type in password or no passowrd. doesnt work. i try root, same problem. i just cant get back into my computer and i have no idea what whent wrong.

im running mandriva live right now, and i cant quite get it to reboot with all my files still intact.
i need to know how to reboot my linux OS with all my files still intact. i tried before with a partition thing and it says it just wont work.
thanks
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • gamekiller
  • Graduate
  • Graduate
  • gamekiller
  • Posts: 101
  • Loc: above the chair

Post 3+ Months Ago

In fedora or redhat based, I usually type "single" at the boot loader before booting into Linux machine.. I'm not sure about mandrive, never try this distro.. What I mean is, try boot it as a single user..

This from my opinion, not really sure whether it works or not, just throwing some ideas :p
  • AnarchY SI
  • Web Master
  • Web Master
  • User avatar
  • Posts: 2521
  • Loc: /usr/src/MI

Post 3+ Months Ago

i'm not sure if / how well this would work, but..
on the live cd, do an su - and there should either be no password or it should be root or toor or the live cd will tell you what it is. then mount your linux partition somewhere, for this example we're going to say you mounted it at /media/mandriva
now that it's mounted, we're going to try something tricky:
Code: [ Select ]
chroot /media/mandriva
passwd your_user_name
type_new_password
type_new_password_again
exit
  1. chroot /media/mandriva
  2. passwd your_user_name
  3. type_new_password
  4. type_new_password_again
  5. exit

reboot and see if it lets you in. you might also try changing the root password while you're chroot'd as well.
i somewhat doubt it will work as that seems like itd be a serious security flaw, but if it does - cheers. worth a try imho

// edit - it worked for me in ubuntu.

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 43 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.