need help with redhat 9

  • Katushai
  • Graduate
  • Graduate
  • User avatar
  • Posts: 152

Post 3+ Months Ago

i wanna do Perl CGI, but i cant cause instead of showing what it should show, its just showing the code i typed. its gettin on my nerves, and to make a long story short i need to enable CGIs in user directories. can somebody PLEASE help me? i would be quite grateful...thanks, late
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9084
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Do you have full access to your server? Like root access? If so you can edit the httpd.conf file and restart the apache server to allow you to run those cgi scripts. You would need to uncomment the Addhandler for the cgi-script .cgi line, as I believe that is commented by default. You would also have to add +ExecCGI to your default Options or a domain by domain basis.

If you do not have full access, your adminstrator may allow you to override some changes using a .htaccess file. If you make a .htaccess file put the following in the file which should allow you to run scripts if the extension is .cgi

Code: [ Select ]
Options +ExecCGI +FollowSymLinks
AddHandler cgi-script .cgi
  1. Options +ExecCGI +FollowSymLinks
  2. AddHandler cgi-script .cgi


Place this file in the directory that you want to run scripts in.
  • Katushai
  • Graduate
  • Graduate
  • User avatar
  • Posts: 152

Post 3+ Months Ago

ok, i cant start httpd cause its looking at the ip 127.0.0.1, and of course thats a loop in the network, but how do i change that in the httpd.conf? i dont wanna mess with anything without knowing what im doin =/
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9084
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Are we talking about a different problem now? or is this based on the other? Wasn't your httpd daemon working before?
  • K!LL3R_TANK
  • Born
  • Born
  • User avatar
  • Posts: 2
  • Loc: new york

Post 3+ Months Ago

i tried adding those lines to my httpd.conf and it didnt seem to work totally at first i got object not found error then after i added those lines i got access denied everyone here i know uses gentoo and is not willing to help me out with my redhat 9 (unless i change to gentoo then they would help)so i am searching on here for some help. i got mysql and php working am using phpbb2 forum for my bf1942 desert combat web page and have found a pearl script that will show a live stats page. i am sure it just something i am missing in the .conf file. i can send anyone a copy of it if they would be willing to help out. i had no problem getting everything to work when i was using a windows server but now that my game server is running under linux i wanted to put up the webpage on the same box i dont get alot of traffic on it anyway is mostly just for clan business and a few allied clans we have. id really like to get this working without using another windows box just for the page.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9084
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Okay I am not sure I am totally understanding what you are saying. So you are on a Linux box using Apache and before when you ran a script text would just show up right? Then you tried doing the suggestion I posted above and at that point you got Access Denied errors? Am I right? Please elaborate. Thanks.
  • K!LL3R_TANK
  • Born
  • Born
  • User avatar
  • Posts: 2
  • Loc: new york

Post 3+ Months Ago

yes but that was a permission and ownership problem which i fixed. after which
i was getting object not found error page.

ok update i removed everything and started with a fresh .conf

i double checked permissions here is the error i get now

Server error!

The server encountered an internal error and was unable to complete your request.

Error message:
Premature end of script headers: bf1942live.pl

to me that looks like it just doent know what to do with it i know the script is good because it runs fine on apache in a windows install

Post Information

  • Total Posts in this topic: 7 posts
  • Users browsing this forum: No registered users and 52 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.