PHP / Apache / Linux

  • saby
  • Born
  • Born
  • saby
  • Posts: 2

Post 3+ Months Ago

Hi,

For a new website, I would like to use php with mySQL databases. I need to install Linux and Apache on my server but I have heard that if I want to use PHP4 and not PHP3, I can't use any of the Linux releases ... same for Apache 4.

Now come the questions :)
Is it true ? If yes, where can I find a list of the supported releases ?

I have also seen PHP5 has just been released. Does it work with any Linux ?

Thank you for your answer

Saby
  • this213
  • Guru
  • Guru
  • User avatar
  • Posts: 1260
  • Loc: ./

Post 3+ Months Ago

PHP 5 does work on Linux. However, because PHP 5 is so new, you might do better to wait a bit (about 6 months) for them to get all the bugs worked out of it, especially if this is for a production server. The best solution is v4.3.8. You can get either at http://php.net

I don't believe the version of Apache to which you are refering is an official distribution. The latest release of Apache is 2.0.50. You can get it at http://apache.org

hth
This
  • saby
  • Born
  • Born
  • saby
  • Posts: 2

Post 3+ Months Ago

Thank you for your answers !
Does PHP4 work with any release of Linux then ?
  • this213
  • Guru
  • Guru
  • User avatar
  • Posts: 1260
  • Loc: ./

Post 3+ Months Ago

As far as I've seen. I know from personal experience that it works with Fedora, RedHat, Mandrake, Debian, FreeBSD and Slackware. That would make me guess it works on any other distribution as well.

What flavor of Linux are you running?

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 11 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.