Problem with configuring package under Ubuntu

  • this213
  • Guru
  • Guru
  • User avatar
  • Posts: 1260
  • Loc: ./

Post 3+ Months Ago

I actually have a problem that I can't figure out - oh, don't look so shocked.

The problem is that the MySQL Control Center can't find qt under Ubuntu, even if --with-qt=/wherever is specified with ./configure. I've stepped through the script enough to see that it's actually looking in the right place, but for some reason it's not reading QT_VERSION properly (defined in qt's qglobal.h). This same script works fine on every other distro I've tried it with and I almost took the "PNF" path until I tried it under Ubuntu for myself - after all, this version has been downloaded almost 800 times in the past 3 weeks and nobody else has reported any weirdness. This morning I had to install CentOS on the system I was using to try to solve this issue, effectively ending any Ubuntu-specific work I can do with it for the time being.

If anyone's interested in getting this working under Ubuntu, there are plenty of people who would appreciate it (myself included). You can download the source tarball or checkout the subversion repo from http://sourceforge.net/projects/mysqlcc
If your fix requires some Ubuntu-specific tweaking (meaning whatever's done to fix it breaks it for the other distros), I'm not beyond setting up a separate release for Ubuntu, though I'd rather not if I don't absolutely have to.

Yes, I do realize that I am, in effect, asking someone else to do my work for me. However, I feel I've given enough to the open source community to be able to make such requests, especially when those requests are to benefit the open source community and specifically, people who aren't me (because you'll never catch me running Ubuntu as my primary desktop OS).

Thanks
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

Post Information

  • Total Posts in this topic: 1 post
  • Users browsing this forum: No registered users and 30 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.