Problem with make command

  • PT
  • Newbie
  • Newbie
  • PT
  • Posts: 9
  • Loc: Delhi , India

Post 3+ Months Ago

I am installing globus toolkit and when i write the following command:
make install

i get the following error:

make: *** No rule to make target 'install'. Stop

I am stuck here...Can anybody please help!
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • spork
  • Brewmaster
  • Silver Member
  • User avatar
  • Posts: 6241
  • Loc: Seattle, WA

Post 3+ Months Ago

The makefile doesn't have an "install" target.
  • PT
  • Newbie
  • Newbie
  • PT
  • Posts: 9
  • Loc: Delhi , India

Post 3+ Months Ago

Thanks for the reply. The problem was that i was running the command from a wrong folder. But after correcting that i have a new problem with

make install

I get the following error:

ln -s /usr/local/globus-4.0.0/etc/gpt/packages /usr/local/globus-4.0.0/etc/globus_packages
ln: creating symbolic link `/usr/local/globus-4.0.0/etc/globus_packages/packages': File exists
make: *** [postinstall] Error 1

It most probably means that the "packages" file already exists.And that the removal of this file would solve this problem but it doesnt. I also tried removing the ln command given in the makefile. But that doesnt work either.
Another thing is that the "etc" given in the path indicates that it must be a folder.But when i searched this "etc" i find that it isnt a folder but some kinda file.And the properties show that the file type is unkown.

Does all this make any sense? If any solution , please tell .
  • spork
  • Brewmaster
  • Silver Member
  • User avatar
  • Posts: 6241
  • Loc: Seattle, WA

Post 3+ Months Ago

Looks like a problem specific to that program, not to 'make' itself. I don't have any knowledge of Globus, so I can't be of much help here. Perhaps someone else can..
  • Janrocks
  • Graduate
  • Graduate
  • User avatar
  • Posts: 165
  • Loc: between

Post 3+ Months Ago

OK.. flying blind, but if theres some kind of file already at /usr/local/globus-4.0.0/etc and not a directory then have you tried deleting that file and doing

mkdir /usr/local/globus-4.0.0/etc

then

make clean
make install

because I think there may be a bug in the makefile or somewhere which is making a file at that location and leaving it there..

You should maybe find the globus irc channel, and possibly post your issue on the bug tracker.

Post Information

  • Total Posts in this topic: 5 posts
  • Users browsing this forum: No registered users and 36 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.