WinXP/Linux Problem please help

  • akha666
  • Born
  • Born
  • akha666
  • Posts: 3
  • Loc: Egypt

Post 3+ Months Ago

Hello everyone
I'm beginner to using Linux . I have WinXP installed on drive C: and Linux Red Hat 7.2 installed on drive D: with ex2 format and I make (LILO) dual booting , when I start my PC I see Red Hat logo screen loading with to choices (Linux / Dos) .
I have 2 Problem with Linux and Dos
1- when I chose Dos to enter in my WinXP it give me at shell prompt error :
error 0X01
Boot : Dos
I searched for this error number on Google and I know it Disk error code
0x01 "Illegal command". This shouldn't happen, but if it does, it may indicate an attempt to access a disk which is not supported by the BIOS. See also "Warning: BIOS drive 0x may not be accessible"
2- when I chose Linux at shell prompt it ask me for
"Localhost login : " . I typed my user that I created in installation of Linux then
"password" I typed my password that I created
and I see at shell prompt "username@localhost" I typed startx to start Linux windows X service , I see error that there is no Xserver (in the installation I chose Skip X configuration) coz I have VGA card GeForce4 MX 440 with AGP8X and it not listed in "Graphical Interface (X) Configuration" I download it driver from (http://www.nvidia.com/object/linux_display_ia32_1.0-6111.html) , I ask if this steps Right or No ? and what should I type after login to start Linux (GNOME/KDE)
my hardware is (CPU 1.7- VGA Geforce4 – MB Chaintech – 256 Ram – CD ROM 52X – Floppy Drive 1.44 – HD 80 Gb)
please can anyone help me to solve this twice problem
thanks :arrow:
  • Bgnn32
  • Banned
  • Banned
  • Bgnn32
  • Posts: 435
  • Loc: Western Mass

Post 3+ Months Ago

Well I can't be much help here, but I have heard that it is hard to get Lilo to work right with XP, if Redhat 7.2 has Grub I would reccomend using that for the boot loader, I have both a desktop and Laptop dual booting XP and Redhat 8 and had no problems at all setting it up.
  • skakid
  • Born
  • Born
  • skakid
  • Posts: 3
  • Loc: Phoenix, AZ

Post 3+ Months Ago

this might help
http://jaeger.morpheus.net/linux/ntldr.html

and to edit the file without a gui you can use nano or pico. as far as installing the xserver, you may want to pop the disks back in and reinstall and choose to install the xserver and kde or gnome.
  • TheArchitect
  • Professor
  • Professor
  • TheArchitect
  • Posts: 764
  • Loc: Australia

Post 3+ Months Ago

Running Lilo from the master boot record and dual booting XP and Slack works perfectly for me. :roll: Just on the side so you guys know. :wink:
  • cheyrou
  • Student
  • Student
  • cheyrou
  • Posts: 74
  • Loc: Singapore

Post 3+ Months Ago

I tried using Lilo once before and if i recall correctly i got the exact same error but whrn i changed to grub the dual boot worked fine.
  • akha666
  • Born
  • Born
  • akha666
  • Posts: 3
  • Loc: Egypt

Post 3+ Months Ago

I'm thanking everyone can help me
I'm downloaded Fedora Core 2 and with WinXp (Dual Boot) and everything it's Okay
First time after install Fedora when I press (Play test Sound) I can't hear anything from Speaker but it work as fine and in the next day when I start my PC and booting into Fedora it hang on loading Screen (in hardware detected) I pressed (Ctrl + Alt + Delete) to restart my PC then I face this Error
GNU GRUB version 0.94 (639k lower/ 261056k upper memory)
Minimal BASH- like line editing is supported. For the first word, TAB lists possible command completions.
Anywhere else TAB lists the possible completions of device / filename
Grub>

This error make install Fedora second time again and when (play test sound) I hear the sound from the speaker. I thought the sound Problem it solved, I change my login style in KDE with sound but it work for once time otherwise the Linux is detect the sound
(the following audio device was detected)
Vendor : Intel Corp
Model : 828011BA/BAM AC' 97 Audio
Module : snd-inte8xo
The sound is detect but doesn't work, what is the solution ?
and my Modem didn't detected in hardware browser .
and how can I access to my hard disk partition in Linux when I open Computer I see (Floppy, CD Rom, File System, Network).
Should I mount the Partitions? And if ,do I lost any data in my hard disk?
Sorry I'm beginner to use Linux but I'm so interesting to use Linux Fedora Core2 and I'm trying to find any Reference to learn me How to use Linux to have experience
Thanks for reading and replying
  • Maxzip
  • Born
  • Born
  • Maxzip
  • Posts: 1

Post 3+ Months Ago

i would like to ask about grub, command line o editing , because i have RH 9.0 with kernel 2.4.20, and winXP in a s-ata drive and linux on an ide hd, but i dont know hot to ad the option to boot from s-ata. can u help me?
  • Jazzy
  • Student
  • Student
  • Jazzy
  • Posts: 72
  • Loc: Brussels

Post 3+ Months Ago

Well it doen't really mke out what drive you have to pass the boot parameters.

Well this is here for LILo atleast:
Dont forget to run /sbin/lilo when finished editing your lilo.conf otherwise no change will be taken into consideration !!

You just need to know what partition your WinXp is on ( hda1/2/3 ..... )

I don't remember exactly but you have to edit your lilo.conf ( /etc/lilo.conf )
and add the partition for your winXP

other=/dev/hdx ( The partition where XP is on )
label=WinXP
table=/dev/hdx ( The HDD where the partition with XP is installed )

*example :

other=/dev/hdb1
label=WinXP
table=/dev/hdb

*



I would recomend to install XP on your master drive. Otherwise you will most likely having some problems

Hope it helps :)

Post Information

  • Total Posts in this topic: 8 posts
  • Users browsing this forum: No registered users and 39 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.