Yet another problem, can't update dependency problem

  • biruru
  • Novice
  • Novice
  • biruru
  • Posts: 31
  • Loc: Toronto

Post 3+ Months Ago

Hi i'm trying to update my fc 6 system but i can't, i get a dependency error with this:

Error: Missing Dependency: liblzo.so.1 is needed by package transcode
Error: Missing Dependency: liblzo.so.1 is needed by package mplayer

does anyone had the same problem? my mplayer is installed from atrpms with mythtv suite, but i use freshrpms for regular install.
[root@localhost ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package lzo.i386 0:2.02-2.fc6 set to be updated
---> Package selinux-policy.noarch 0:2.4.1-3.fc6 set to be updated
---> Package pygtk2.i386 0:2.10.3-2.fc6 set to be updated
---> Package tcsh.i386 0:6.14-12 set to be updated
---> Package rsh.i386 0:0.17-37.fc6 set to be updated
---> Package bluez-utils.i386 0:3.7-2 set to be updated
---> Package audit-libs.i386 0:1.2.9-1.fc6 set to be updated
---> Package bluez-gnome.i386 0:0.6-1.fc6 set to be updated
---> Package xine.i386 0:0.99.4-6.fc6 set to be updated
---> Package bind-utils.i386 30:9.3.3-4.fc6 set to be updated
---> Package xsane.i386 0:0.991-4.fc6 set to be updated
---> Package libfame.i386 0:0.9.1-12.fc6 set to be updated
---> Package libxslt.i386 0:1.1.18-1.FC6 set to be updated
---> Package beagle.i386 0:0.2.10-5.fc6 set to be updated
---> Package system-config-users.noarch 0:1.2.47-1.fc6 set to be updated
---> Package shadow-utils.i386 2:4.0.17-9.fc6 set to be updated
---> Package eject.i386 0:2.1.5-4.1.fc6 set to be updated
---> Package tar.i386 2:1.15.1-21.fc6 set to be updated
---> Package hplip.i386 0:1.6.10-1.fc6.4 set to be updated
---> Package libgpod.i386 0:0.4.0-0.fc6 set to be updated
---> Package xsane-gimp.i386 0:0.991-4.fc6 set to be updated
---> Package wpa_supplicant.i386 1:0.4.9-1.fc6 set to be updated
---> Package anacron.i386 0:2.3-44.fc6 set to be updated
---> Package a2ps.i386 0:4.13b-57.fc6.3 set to be updated
---> Package hpijs.i386 1:1.6.10-1.fc6.4 set to be updated
---> Package libsane-hpaio.i386 0:1.6.10-1.fc6.4 set to be updated
---> Package firefox.i386 0:1.5.0.7-8.fc6 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.4.1-3.fc6 set to be updated
---> Package gaim.i386 2:2.0.0-0.17.beta4.fc6 set to be updated
---> Package audacity.i386 0:1.2.5-2.fc6 set to be updated
---> Package pygtk2-libglade.i386 0:2.10.3-2.fc6 set to be updated
---> Package system-config-date.noarch 0:1.8.8-1.fc6 set to be updated
---> Package beagle-gui.i386 0:0.2.10-5.fc6 set to be updated
---> Package gnome-applets.i386 1:2.16.0.1-10.fc6 set to be updated
---> Package libbeagle.i386 0:0.2.10-5.fc6 set to be updated
---> Package libxml2-python.i386 0:2.6.27-1.FC6 set to be updated
---> Package libsepol.i386 0:1.15.1-1.fc6 set to be updated
---> Package scim-bridge.i386 0:0.4.7-1.fc6 set to be updated
---> Package vnc-server.i386 0:4.1.2-5.fc6 set to be updated
---> Package pygobject2.i386 0:2.12.2-1.fc6 set to be updated
---> Package libxml2.i386 0:2.6.27-1.FC6 set to be updated
---> Package pango.i386 0:1.14.6-2.fc6 set to be updated
---> Package evolution-data-server.i386 0:1.8.1-1.fc6 set to be updated
---> Package autofs.i386 1:5.0.1-0.rc2.17 set to be updated
---> Package scim-bridge-gtk.i386 0:0.4.7-1.fc6 set to be updated
---> Package rhgb.i386 0:0.16.4-3.fc6 set to be updated
---> Package bind-libs.i386 30:9.3.3-4.fc6 set to be updated
---> Package audit-libs-python.i386 0:1.2.9-1.fc6 set to be updated
---> Package gdm.i386 1:2.16.0-18.fc6 set to be updated
---> Package gnome-screensaver.i386 0:2.16.1-2.fc6 set to be updated
---> Package gtkhtml3.i386 0:3.12.1-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: liblzo.so.1 for package: transcode
--> Processing Dependency: liblzo.so.1 for package: mplayer
--> Processing Dependency: xine-lib-extras >= 1.1.2 for package: xine
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xine-lib-extras.i386 0:1.1.2-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: liblzo.so.1 for package: transcode
--> Processing Dependency: liblzo.so.1 for package: mplayer
--> Finished Dependency Resolution
Error: Missing Dependency: liblzo.so.1 is needed by package transcode
Error: Missing Dependency: liblzo.so.1 is needed by package mplayer
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • AnarchY SI
  • Web Master
  • Web Master
  • User avatar
  • Posts: 2521
  • Loc: /usr/src/MI

Post 3+ Months Ago

http://stanton-finley.net/fedora_core_5 ... ml#Warning
http://fedoraproject.org/wiki/JohnMahow ... pmsWarning
http://dag.wieers.com/home-made/apt/FAQ.php#D1
  • biruru
  • Novice
  • Novice
  • biruru
  • Posts: 31
  • Loc: Toronto

Post 3+ Months Ago

anyway to exclude this dependency from package transcode and mplayer to allow the auto update? I haven't been able to update since fresh install.
  • AnarchY SI
  • Web Master
  • Web Master
  • User avatar
  • Posts: 2521
  • Loc: /usr/src/MI

Post 3+ Months Ago

# yum -y install yumex
# yumex
click on the update button on the left side after it loads up. select the updates you want (obviously minus mplayer / transcode, and make sure atrpms isn't being loaded. you should probably remove their repo from your repo sources but if not *shrug* whatev), click 'add to queue and process' and let it do its thing.

thats the easy way of doing it.

if you want to stay at the command line USUALLY when people want help they try things like yum --help
'man yum' is another good one.
;)
  • biruru
  • Novice
  • Novice
  • biruru
  • Posts: 31
  • Loc: Toronto

Post 3+ Months Ago

Anarchy SI, yup, yumex is easier to update. So the only thing i was able to update is lzo, is this important for any other software besides mplayer and transcode?
  • AnarchY SI
  • Web Master
  • Web Master
  • User avatar
  • Posts: 2521
  • Loc: /usr/src/MI

Post 3+ Months Ago

"So the only thing i was able to update is lzo" *wasn't ;)

Quote:
LZO is a data compression library which is suitable for data de-/compression in real-time. This means it favours speed over compression ratio.
- http://www.oberhumer.com/opensource/lzo/

as long as no other media program that uses that encoder/decoder exists on your pc then nah, you're good. lol

Post Information

  • Total Posts in this topic: 6 posts
  • Users browsing this forum: No registered users and 72 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.