Adding a .swf to a webpage

  • romio
  • Beginner
  • Beginner
  • romio
  • Posts: 58

Post 3+ Months Ago

Please help:

I am new here..

well i am trying to add a .swf to my web.. I don't know who to do that.

I know that i have to generate come codes.. well here are the codes.

Code: [ Select ]
<object classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
codebase=http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,2,0
width=600
height=300>
<param name=movie value=matrix.swf>
<param name=quality value=high>
<param name=BGCOLOR value=#000000>
<param name=SCALE value=showall>
<embed src=matrix.swf
quality=high
pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash type=application/x-shockwave-flash
width=500
height=100
bgcolor=#000000
scale= showall>
</embed>
</object>
  1. <object classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
  2. codebase=http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,2,0
  3. width=600
  4. height=300>
  5. <param name=movie value=matrix.swf>
  6. <param name=quality value=high>
  7. <param name=BGCOLOR value=#000000>
  8. <param name=SCALE value=showall>
  9. <embed src=matrix.swf
  10. quality=high
  11. pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash type=application/x-shockwave-flash
  12. width=500
  13. height=100
  14. bgcolor=#000000
  15. scale= showall>
  16. </embed>
  17. </object>


and this is my html codes



Code: [ Select ]
<p align=center><a href="??"><img border="0" src=
"??/matrix.swf"><a/>

<br><br>
  1. <p align=center><a href="??"><img border="0" src=
  2. "??/matrix.swf"><a/>
  3. <br><br>


how can i do this..

?? represent my web address
Thanks
  • Socno
  • Graduate
  • Graduate
  • Socno
  • Posts: 107
  • Loc: New York

Post 3+ Months Ago

romio wrote:
Please help:

I am new here..

well i am trying to add a .swf to my web.. I don't know who to do that.

I know that i have to generate come codes.. well here are the codes.

<object classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
codebase=http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,2,0
width=600
height=300>
<param name=movie value=matrix.swf>
<param name=quality value=high>
<param name=BGCOLOR value=#000000>
<param name=SCALE value=showall>
<embed src=matrix.swf
quality=high
pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash type=application/x-shockwave-flash
width=500
height=100
bgcolor=#000000
scale= showall>
</embed>
</object>


and this is my html codes



<p align=center><a href="??"><img border="0" src=
"??/matrix.swf"><a/>

<br><br>
how can i do this..

?? represent my web address
Thanks


Just upload the .swf file. You do not have to insert the .swf file into a html document.
  • romio
  • Beginner
  • Beginner
  • romio
  • Posts: 58

Post 3+ Months Ago

I didnt really understand what u said...

i have uploaded the .swf and .txt file... and u told me to remove the txt file .. well i did.. still not working

but the above coding is it right

dont i have to put the link of the swf on the generated codes

what is the coding of uploading the file.. i wrote <img... i think its wrong


Please explain more to me
  • romio
  • Beginner
  • Beginner
  • romio
  • Posts: 58

Post 3+ Months Ago

well i have removed the

Code: [ Select ]
<p align=center><a href="??"><img border="0" src=
"??/matrix.swf"><a/>
  1. <p align=center><a href="??"><img border="0" src=
  2. "??/matrix.swf"><a/>


the only thing i can see is a black box....
  • romio
  • Beginner
  • Beginner
  • romio
  • Posts: 58

Post 3+ Months Ago

well.. it works not.... but the fonts are too small
  • Socno
  • Graduate
  • Graduate
  • Socno
  • Posts: 107
  • Loc: New York

Post 3+ Months Ago

This is what you do. When you are using Flash. You are working on a .fla file. If you export this into a move (.swf) you will get a file called "flaFILE".swf

Upload this file into your server.

The url would then be: http://www.myurl.com/filename.swf

Get it?
  • digitalMedia
  • a.k.a. dM
  • Genius
  • User avatar
  • Posts: 5146
  • Loc: SC-USA

Post 3+ Months Ago

//moved

romio: Please use the BBCode when posting sections of HTML, etc.

Thanks
  • hyparzero
  • Newbie
  • Newbie
  • hyparzero
  • Posts: 5

Post 3+ Months Ago

that's easy dudes, this is your code:

Code: [ Select ]
<object classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
codebase=http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,2,0
width=600
height=300>
<param name=movie value=matrix.swf>
<param name=quality value=high>
<param name=BGCOLOR value=#000000>
<param name=SCALE value=showall>
<embed src=matrix.swf
quality=high
pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash type=application/x-shockwave-flash
width=500
height=100
bgcolor=#000000
scale= showall>
</embed>
</object>
  1. <object classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
  2. codebase=http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,2,0
  3. width=600
  4. height=300>
  5. <param name=movie value=matrix.swf>
  6. <param name=quality value=high>
  7. <param name=BGCOLOR value=#000000>
  8. <param name=SCALE value=showall>
  9. <embed src=matrix.swf
  10. quality=high
  11. pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash type=application/x-shockwave-flash
  12. width=500
  13. height=100
  14. bgcolor=#000000
  15. scale= showall>
  16. </embed>
  17. </object>


you need to add the above code into your HTML, example:

Code: [ Select ]
p align=center>
<a href=""><object classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
codebase=http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,2,0
width=600
height=300>
<param name=movie value=matrix.swf>
<param name=quality value=high>
<param name=BGCOLOR value=#000000>
<param name=SCALE value=showall>
<embed src=matrix.swf
quality=high
pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash type=application/x-shockwave-flash
width=500
height=100
bgcolor=#000000
scale= showall>
</embed>
</object></a>
  1. p align=center>
  2. <a href=""><object classid=clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
  3. codebase=http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,2,0
  4. width=600
  5. height=300>
  6. <param name=movie value=matrix.swf>
  7. <param name=quality value=high>
  8. <param name=BGCOLOR value=#000000>
  9. <param name=SCALE value=showall>
  10. <embed src=matrix.swf
  11. quality=high
  12. pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash type=application/x-shockwave-flash
  13. width=500
  14. height=100
  15. bgcolor=#000000
  16. scale= showall>
  17. </embed>
  18. </object></a>


you can't use the
Code: [ Select ]
<img src>
tag for Flash files...
  • jlknauff
  • Expert
  • Expert
  • User avatar
  • Posts: 502
  • Loc: Florida

Post 3+ Months Ago

I don't know how concerned you are with having valid html but here is something that ATNO/TW helped me out with so I figured I would pass it on. Try this:

Code: [ Select ]
<object type="application/x-shockwave-flash"
data="img/vssindex.swf"
width="165" height="262px">
  <param name="movie"
value="img/vssindex.swf" />
 </object>
  1. <object type="application/x-shockwave-flash"
  2. data="img/vssindex.swf"
  3. width="165" height="262px">
  4.   <param name="movie"
  5. value="img/vssindex.swf" />
  6.  </object>


Just change the path and dimensions. It cleans up & shortens your code plus make it valid HTML. Good luck
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6375
  • Loc: twitter.com/unflux

Post 3+ Months Ago

the problem with that jlknauff, is objects are only for IE. You will still need a second tag, for mozilla/NS:
Code: [ Select ]
<embed>
  • jlknauff
  • Expert
  • Expert
  • User avatar
  • Posts: 502
  • Loc: Florida

Post 3+ Months Ago

Ahhh. Question then-It works fine for me in NS 7.1 so is it only a problem on older versions?
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6375
  • Loc: twitter.com/unflux

Post 3+ Months Ago

that is also a good question, and would make sense if it were true. i have never tested
it, since the rule has been to use both to prevent a problem. might be worth testing out
sometime though.
  • jlknauff
  • Expert
  • Expert
  • User avatar
  • Posts: 502
  • Loc: Florida

Post 3+ Months Ago

wouldn't it make it invalid html then?

Post Information

  • Total Posts in this topic: 13 posts
  • Users browsing this forum: No registered users and 21 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.