background image not showing

  • Tazel
  • Student
  • Student
  • Tazel
  • Posts: 97

Post 3+ Months Ago

http://www.maxedge.net

Below the logo, there is supposed to be another bar with links. In Mozilla Firebird, it shows fine but in the horrid Internet Explorer, it doesn't show. I've reviewed my code and I can't find the flaw in it. Maybe the problem is in some other browsers but I'm pretty sure that it's only in IE.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

I think what may be messing you up is the height=100% in your first table, tr and td tags. Basically, I think you're confusing the heck out of IE. This is a reverse scenario case. Normally, I.E. overlooks errors and Mozilla doesn't, but I think if you experiment with elliminating that height thing wherever you find it, it will get you closer. Basically you're telling your table to take up 100% of the height of the page.

You also don't have a closing </html> tag. I doubt that's the issue.

The other thing you could do is run the page through the validator at
http://validator.w3.org to see the additional errors.

But when you do, it's going to tell you that it couldn't find the character encoding. To fix that change your doctype (DTD) to this:
Code: [ Select ]
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
  2. "http://www.w3.org/TR/REC-html40/loose.dtd">


And the first thing in your head tags add this:
Code: [ Select ]
<!--
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">-->
  1. <!--
  2. <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">-->


So the very first lines of your document would look like this:
Code: [ Select ]
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<head>
<!--
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">-->
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
  2. "http://www.w3.org/TR/REC-html40/loose.dtd">
  3. <html>
  4. <head>
  5. <!--
  6. <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">-->


(That may actually help with the IE problem before you even make any changes to the code, but I doubt it. I think the height attribute is your culprit.)

Cheers.
  • digitalMedia
  • a.k.a. dM
  • Genius
  • User avatar
  • Posts: 5149
  • Loc: SC-USA

Post 3+ Months Ago

your applying background attributes to the rows. i've always found it more effective to apply them to the TABLE or TD. Since you're using style sheets, why don't you just use those to set a background attribute in one of the elements there?
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

I missed that. the TR element doesn't have any valid attributes. There shouldn't be any there. Sorry I missed that.
  • Tazel
  • Student
  • Student
  • Tazel
  • Posts: 97

Post 3+ Months Ago

Allright, now the problem is, in IE, the TOP bar is too big heightwise. I have no definition other than 2% which should be smalle than the bar content so it wraps. But it's still way big! Now what's the problem?
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

I'd say the first problem is you didn't follow my instructions. If you don't get the Doctype definition right and you don't get the character set right, you are going to have problems with your code, plain and simple.

//p.s. you still haven't closed your ending html tag
  • Tazel
  • Student
  • Student
  • Tazel
  • Posts: 97

Post 3+ Months Ago

Alright I followed your instructions. But the problem with the top bar still exists. It's just too big. I don't have any properties defined for it concerning height other than the cellpadding and I've fiddled with that already and that's not the problem.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

Here's what I have so far:

Code: [ Select ]
Below are the results of attempting to parse this document with an SGML parser.

Line 48, column 35: there is no attribute "TOPMARGIN" (explain...).
  <body bgcolor="#FFFFFF" topmargin="0" leftmargin="0" marginwidth="0" marginheig
                   ^
Line 48, column 50: there is no attribute "LEFTMARGIN" (explain...).
 ...r="#FFFFFF" topmargin="0" leftmargin="0" marginwidth="0" marginheight="0" bor
                     ^
Line 48, column 66: there is no attribute "MARGINWIDTH" (explain...).
 ..."#FFFFFF" topmargin="0" leftmargin="0" marginwidth="0" marginheight="0" border=0>
                            ^
Line 48, column 83: there is no attribute "MARGINHEIGHT" (explain...).
 ...gin="0" marginwidth="0" marginheight="0" border=0>
                     ^
Line 48, column 94: there is no attribute "BORDER" (explain...).
 ...ginwidth="0" marginheight="0" border=0>
                     ^
Line 50, column 29: there is no attribute "HEIGHT" (explain...).
  <table width="100%" height="100%" cellpadding="0" cellspacing="0" border=0 val
                ^
Line 50, column 84: there is no attribute "VALIGN" (explain...).
 ...="0" cellspacing="0" border=0 valign=top>
                     ^
Line 51, column 13: there is no attribute "WIDTH" (explain...).
   <tr width=100%>
        ^
Line 51, column 16: an attribute value must be a literal unless it contains only name characters (explain...).
   <tr width=100%>
         ^
Line 55, column 8: invalid comment declaration
   <!--middle/content---------->
     ^
Line 52, column 4: comment declaration started here (explain...).
   <!--left-------------------->
   ^
Line 55, column 9: character data is not allowed here
   <!--middle/content---------->
      ^
Line 70, column 13: element "NOBR" undefined (explain...).
     <nobr>
        ^
Line 82, column 19: invalid comment declaration
    <!---/end #1--->
           ^
Line 82, column 5: comment declaration started here (explain...).
    <!---/end #1--->
    ^
Line 84, column 14: invalid comment declaration
    <!---#1---table \/ header logo&below---->
        ^
Line 84, column 5: comment declaration started here (explain...).
    <!---#1---table \/ header logo&below---->
    ^
Line 84, column 36: cannot generate system identifier for general entity "below----"
    <!---#1---table \/ header logo&below---->
                   ^
Line 84, column 36: general entity "below----" not defined and no default entity (explain...).
    <!---#1---table \/ header logo&below---->
                   ^
Line 84, column 45: reference to entity "below----" for which no system identifier could be generated
    <!---#1---table \/ header logo&below---->
                        ^
Line 84, column 35: entity was defined here
    <!---#1---table \/ header logo&below---->
                   ^
Line 88, column 71: required attribute "ALT" not specified (explain...).
 ...src="/resources/imglink/maxtest4.gif" border=0></a>
                          ^
Line 97, column 15: element "NOBR" undefined (explain...).
      <nobr>
         ^
Line 118, column 14: invalid comment declaration
    <!--#2--left nav stuff-->
        ^
Line 118, column 6: comment declaration started here (explain...).
    <!--#2--left nav stuff-->
    ^
Line 119, column 23: an attribute value must be a literal unless it contains only name characters (explain...).
     <table width=100%>
             ^
Line 127, column 19: an attribute value must be a literal unless it contains only name characters (explain...).
    <td width=100%>
           ^
Line 129, column 23: an attribute value must be a literal unless it contains only name characters (explain...).
     <table width=100%>
             ^
Line 134, column 16: document type does not allow element "HR" here; missing one of "APPLET", "OBJECT", "MAP", "IFRAME", "BUTTON" start-tag
        <hr>
         ^
Line 169, column 16: end tag for element "SPAN" which is not open (explain...).
      </span>
         ^
Line 175, column 13: document type does not allow element "HR" here; missing one of "APPLET", "OBJECT", "MAP", "IFRAME", "BUTTON" start-tag
      <hr>
        ^
Line 192, column 5: invalid comment declaration
  <!--end #0-->
    ^
Line 187, column 3: comment declaration started here (explain...).
   <!--right-------------------->
   ^
Line 192, column 6: character data is not allowed here
  <!--end #0-->
    ^
Line 193, column 6: end tag for "TABLE" omitted, but its declaration does not permit this (explain...).
 </body>
    ^
Line 50, column 2: start tag was here (explain...).
  <table width="100%" height="100%" cellpadding="0" cellspacing="0" border=0 val
  
  1. Below are the results of attempting to parse this document with an SGML parser.
  2. Line 48, column 35: there is no attribute "TOPMARGIN" (explain...).
  3.   <body bgcolor="#FFFFFF" topmargin="0" leftmargin="0" marginwidth="0" marginheig
  4.                    ^
  5. Line 48, column 50: there is no attribute "LEFTMARGIN" (explain...).
  6.  ...r="#FFFFFF" topmargin="0" leftmargin="0" marginwidth="0" marginheight="0" bor
  7.                      ^
  8. Line 48, column 66: there is no attribute "MARGINWIDTH" (explain...).
  9.  ..."#FFFFFF" topmargin="0" leftmargin="0" marginwidth="0" marginheight="0" border=0>
  10.                             ^
  11. Line 48, column 83: there is no attribute "MARGINHEIGHT" (explain...).
  12.  ...gin="0" marginwidth="0" marginheight="0" border=0>
  13.                      ^
  14. Line 48, column 94: there is no attribute "BORDER" (explain...).
  15.  ...ginwidth="0" marginheight="0" border=0>
  16.                      ^
  17. Line 50, column 29: there is no attribute "HEIGHT" (explain...).
  18.   <table width="100%" height="100%" cellpadding="0" cellspacing="0" border=0 val
  19.                 ^
  20. Line 50, column 84: there is no attribute "VALIGN" (explain...).
  21.  ...="0" cellspacing="0" border=0 valign=top>
  22.                      ^
  23. Line 51, column 13: there is no attribute "WIDTH" (explain...).
  24.    <tr width=100%>
  25.         ^
  26. Line 51, column 16: an attribute value must be a literal unless it contains only name characters (explain...).
  27.    <tr width=100%>
  28.          ^
  29. Line 55, column 8: invalid comment declaration
  30.    <!--middle/content---------->
  31.      ^
  32. Line 52, column 4: comment declaration started here (explain...).
  33.    <!--left-------------------->
  34.    ^
  35. Line 55, column 9: character data is not allowed here
  36.    <!--middle/content---------->
  37.       ^
  38. Line 70, column 13: element "NOBR" undefined (explain...).
  39.      <nobr>
  40.         ^
  41. Line 82, column 19: invalid comment declaration
  42.     <!---/end #1--->
  43.            ^
  44. Line 82, column 5: comment declaration started here (explain...).
  45.     <!---/end #1--->
  46.     ^
  47. Line 84, column 14: invalid comment declaration
  48.     <!---#1---table \/ header logo&below---->
  49.         ^
  50. Line 84, column 5: comment declaration started here (explain...).
  51.     <!---#1---table \/ header logo&below---->
  52.     ^
  53. Line 84, column 36: cannot generate system identifier for general entity "below----"
  54.     <!---#1---table \/ header logo&below---->
  55.                    ^
  56. Line 84, column 36: general entity "below----" not defined and no default entity (explain...).
  57.     <!---#1---table \/ header logo&below---->
  58.                    ^
  59. Line 84, column 45: reference to entity "below----" for which no system identifier could be generated
  60.     <!---#1---table \/ header logo&below---->
  61.                         ^
  62. Line 84, column 35: entity was defined here
  63.     <!---#1---table \/ header logo&below---->
  64.                    ^
  65. Line 88, column 71: required attribute "ALT" not specified (explain...).
  66.  ...src="/resources/imglink/maxtest4.gif" border=0></a>
  67.                           ^
  68. Line 97, column 15: element "NOBR" undefined (explain...).
  69.       <nobr>
  70.          ^
  71. Line 118, column 14: invalid comment declaration
  72.     <!--#2--left nav stuff-->
  73.         ^
  74. Line 118, column 6: comment declaration started here (explain...).
  75.     <!--#2--left nav stuff-->
  76.     ^
  77. Line 119, column 23: an attribute value must be a literal unless it contains only name characters (explain...).
  78.      <table width=100%>
  79.              ^
  80. Line 127, column 19: an attribute value must be a literal unless it contains only name characters (explain...).
  81.     <td width=100%>
  82.            ^
  83. Line 129, column 23: an attribute value must be a literal unless it contains only name characters (explain...).
  84.      <table width=100%>
  85.              ^
  86. Line 134, column 16: document type does not allow element "HR" here; missing one of "APPLET", "OBJECT", "MAP", "IFRAME", "BUTTON" start-tag
  87.         <hr>
  88.          ^
  89. Line 169, column 16: end tag for element "SPAN" which is not open (explain...).
  90.       </span>
  91.          ^
  92. Line 175, column 13: document type does not allow element "HR" here; missing one of "APPLET", "OBJECT", "MAP", "IFRAME", "BUTTON" start-tag
  93.       <hr>
  94.         ^
  95. Line 192, column 5: invalid comment declaration
  96.   <!--end #0-->
  97.     ^
  98. Line 187, column 3: comment declaration started here (explain...).
  99.    <!--right-------------------->
  100.    ^
  101. Line 192, column 6: character data is not allowed here
  102.   <!--end #0-->
  103.     ^
  104. Line 193, column 6: end tag for "TABLE" omitted, but its declaration does not permit this (explain...).
  105.  </body>
  106.     ^
  107. Line 50, column 2: start tag was here (explain...).
  108.   <table width="100%" height="100%" cellpadding="0" cellspacing="0" border=0 val
  109.   
  • gsv2com
  • Professor
  • Professor
  • User avatar
  • Posts: 776
  • Loc: Nippon

Post 3+ Months Ago

I'm not sure exactly what the problem is, but my guess is it's inside one of your tables. For being a CSS user as you seem, you rely way too much on tables for such a simple design. You could easily do that whole page with one single table. You've got at least seven separate tables in that design! No wonder you're having problems. Use one table for the absolute top and let CSS handle the rest of your layout. Then you'll probably have no trouble figuring out where the problem is. Your code could easily be cut in 1/3.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

To interpret that above...you have a multitude of errors in your code, which explains why there is such a decrepancy between how Firebird displays it and how IE displays it. You won't be able to get them to atch up until you study and learn how to fix the errors in your code.
  • gsv2com
  • Professor
  • Professor
  • User avatar
  • Posts: 776
  • Loc: Nippon

Post 3+ Months Ago

Exactly. :lol: The man!
  • Tazel
  • Student
  • Student
  • Tazel
  • Posts: 97

Post 3+ Months Ago

If you mean use css by using divs, I already tried that and I've had a hell of a time trying to make that work. Was there another way you had in mind?
  • gsv2com
  • Professor
  • Professor
  • User avatar
  • Posts: 776
  • Loc: Nippon

Post 3+ Months Ago

divs should work like a champ. keep trying. if you fail, try again. otherwise you'll never learn. tables should always be a last resort. they're useful for complex layouts, but otherwise should be avoided IMHO.

Post Information

  • Total Posts in this topic: 13 posts
  • Users browsing this forum: No registered users and 50 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.