Cant get youtube video to go behind other elements

  • ben_sigma
  • Beginner
  • Beginner
  • User avatar
  • Posts: 58
  • Loc: South Australia

Post 3+ Months Ago

Does anyone know how to get a youtube video or any flash content for that matter to run behind other page elements.

PROBLEM: I have a scrolling page but some elements are in a fixed position, Such as menus. So when i scroll the page everything scrolls behind the menu except for the flv. that comes on top of the menu.
I have also tried putting the "z-index: 2;" attribute into styles of the object and the embed tags.

Help is appreciated.
  • righteous_trespasser
  • Scuffle
  • Genius
  • User avatar
  • Posts: 6230
  • Loc: South-Africa

Post 3+ Months Ago

as I recall, the item you want to use a "z-index" on must have some positioning set, either relative or absolute ... Or that's what I can recall at least ...
  • mindfullsilence
  • Professor
  • Professor
  • User avatar
  • Posts: 854

Post 3+ Months Ago

R_T is right, I've been coding the css for my site for about 2 days straight now because there's like a billion layers. postion:absolute is the only one that works with z-index for all browsers.
  • gonzoka
  • Student
  • Student
  • gonzoka
  • Posts: 75
  • Loc: Bristol, UK

Post 3+ Months Ago

Make sure the flash movie is embedded with the wmode set correctly. If i remember right, it needs to be transparent, but theres not many options to choose from. See http://www.adobe.com/go/tn_15523 for info on it...

HTH

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 55 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.