css bug in ie7 (unordered lists)

  • ohyourenofun
  • Born
  • Born
  • ohyourenofun
  • Posts: 3

Post 3+ Months Ago

hi,
i do web design work for my school and i recently started working on a new layout. it (should) look fine in firefox, but in internet explorer the two unordered lists (left and right navigation) are shifted over to the right. i validated the xhtml & css and everything is apparently fine. now the hard part is finding what element isn't agreeing in internet explorer! :( would anyone be willing to help? below are links to the page and the css. thanks!!

http://nemo.mwd.hartford.edu/~tvars/parttime/test.htm
http://nemo.mwd.hartford.edu/~tvars/par ... letest.htm
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • digitalMedia
  • a.k.a. dM
  • Genius
  • User avatar
  • Posts: 5149
  • Loc: SC-USA

Post 3+ Months Ago

It's the margin or padding on the UL or LI elements that renders differently in IE, FireFox, et al.

My advise is to set them all equal to 0, then adjust them.
  • ohyourenofun
  • Born
  • Born
  • ohyourenofun
  • Posts: 3

Post 3+ Months Ago

the only way it works is by using negative margins.. i always considered this "cheating" haha.. is there any way around it? if not its fine, now it works!

edit: nevermind, fixed it with just 0px left borders & margins.. thanks!!

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 71 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.