Voting Chart

Total votes : 4

Do you code for cross-compatibility with NS 4.x browsers?

Poll ended at July 2nd, 2003, 8:01 pm.

  •  
    yes
  •  
    no
  •  
    sometimes

CSS crashes NS 4.78

  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

I've heard of this happening before, but the style sheet I just revised crashes NS 4.x (well - for sure I know it crashes 4.78 - I assume it does it on all NS 4.x versions) on one particular page I just revised for a client.

Page affected:
http://dpmcusa.com/faq.html
Style sheet:
http://dpmcusa.com/dpmc.css

Specifics:
Page affected validates for XHTML
Page affected validates for CSS
Page displays as intended in MSIE 6.0, NS 7.0, NS 6.0, Mozilla 1.3 (those are the only browsers I checked so far). No other browser I tested crashes on this page.
NS 4.78 displayed this page OK until I added the Aqua background color to the style for the FAQ answers.
I use the same style for this page http://dpmcusa.com/fee.html which does not crash the browser.

The style class I added was td.formbody2 (I was originally using .formbody class, but when it crashed, I remembered that NS 4.x was lousy with parsing tables, so I copied and pasted and made it part of a table data class and renamed it slightly). Didn't matter though, still crashed anyway.

The style was the only thing I changed in an effort to add more color to the page. I'm sure it's the culprit, but I must be overlooking something. After an hour of looking, I hoped maybe a different set of eyes could see what I'm missing. (I hate coding for crossbrowser compatibility!!! *lol especially NS 4.x)

Any thoughts, tips, suggestions?
Thanks
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9086
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

From what I see you have a div tag nested inside another div tag. This will cause the browser to crash in Netscape 4.78 the majority of the time. If it does not crash it will usually prevent the CSS data from loading, and maybe other weird behavior.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9086
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

It starts here:

Code: [ Select ]
<div id="beginning" class="c1">
...
...
...
...
<div class="c1">
  1. <div id="beginning" class="c1">
  2. ...
  3. ...
  4. ...
  5. ...
  6. <div class="c1">


From what I can see there is no closing div tag before that second one starts, thus it is now nested causing your browser to crash.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

I'm sure that's what I missed. I'll work through that a little later on today. There was something nagging at the back of my mind. I knew I had seen that problem before, but couldn't recall what caused it. But now that you point it out, that was it.

Thanks for taking the time to look. (I also take it I have you to thank for adding the "sometimes" to the poll? If so, thanks).
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9086
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Yup I added that to the poll because my answer wasn't yes or no haha. Didn't think you would mind :)
  • UNFLUX
  • Genius
  • Genius
  • User avatar
  • Posts: 6376
  • Loc: twitter.com/unflux

Post 3+ Months Ago

i don't use pure css too often, but when i do it depends on the extent to
what i need it for. basically, as i voted, i do sometimes. Most of my
designs look ok in every browser, or at least viewable. NS needs to get
with the program tho and standardize with IE. It's getting there tho.
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

It wasn't the nested tags causing the NS 4.x to crash. It was the <object> element for one of the Flash ad banners I was using. Still haven't quite figured out why, because it was identical to the other one that is still on the page other than the filename.

Anyway, once I removed it no more crash. Netscape just must not of liked where I was positioning it in the table, I guess. They always have been pretty lousy about tables.

Thanks for the advice all.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9086
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Netscape 4.x sure is sensitive.

Post Information

  • Total Posts in this topic: 8 posts
  • Users browsing this forum: No registered users and 87 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.