CSS Problem Renders Fine In IE 7 Off in IE6

  • CStrauss
  • Graduate
  • Graduate
  • User avatar
  • Posts: 122
  • Loc: St. Louis MO. USA

Post 3+ Months Ago

I wonder if anyone can help me why my home page does not render correctly in IE 6. It looks fine in FF and IE 7 and other browser just IE 6 is displaying my RSS feed on the wrong side it should be on the right side of the page.

Here is the link to the home page.

http://forsakensoul.com

Here is my css code Im using for that page
Code: [ Select ]
html,body{margin:0;padding:0; background-color:#000;}
body{font: 76% arial,sans-serif;text-align:center; color:#FFF;}
#header{width:1000px; height:180px; background-color:#000;}
#subheader{width:1000px; height:204px; background-color:#000;}
#subheader2{width:1000px; height:357px; background-color:#000;}
#container{width:1000px; margin:0 auto; background-color:#000; text-align:left; border:#8F8C01 solid 1px; /*background-color:#00FF00;*/}
#content{width:1000px; /*background-color:#00FFFF;*/}
#footer{width: 1000px; /*background-color:#006666;*/ padding-top:10px;}
.footer-content{text-align:center;}
.footer-left{text-align:left; margin-left:15px;}


/* Home Content*/
#left{width:500px; float:left; margin-left:10px; margin-right:10px; /*background-color:#00FF00;*/}
#latestnews{width:500px; text-align:justify;}
.title{color:#0066CC;}
#latestnews .article-preview{padding-bottom:5px;}
#projects{width:500px; /*background-color:#FF0000;*/ float:left; margin-top:10px; margin-left:10px; margin-right:10px;}

#right{width:470px; float:left; margin-right:10px; /*background-color:#0066CC;*/}
#rss{width:470px; text-align:justify;}
#affilates{width:300px; /*background-color:#0000FF;*/ float:left; margin-top:10px;}
  1. html,body{margin:0;padding:0; background-color:#000;}
  2. body{font: 76% arial,sans-serif;text-align:center; color:#FFF;}
  3. #header{width:1000px; height:180px; background-color:#000;}
  4. #subheader{width:1000px; height:204px; background-color:#000;}
  5. #subheader2{width:1000px; height:357px; background-color:#000;}
  6. #container{width:1000px; margin:0 auto; background-color:#000; text-align:left; border:#8F8C01 solid 1px; /*background-color:#00FF00;*/}
  7. #content{width:1000px; /*background-color:#00FFFF;*/}
  8. #footer{width: 1000px; /*background-color:#006666;*/ padding-top:10px;}
  9. .footer-content{text-align:center;}
  10. .footer-left{text-align:left; margin-left:15px;}
  11. /* Home Content*/
  12. #left{width:500px; float:left; margin-left:10px; margin-right:10px; /*background-color:#00FF00;*/}
  13. #latestnews{width:500px; text-align:justify;}
  14. .title{color:#0066CC;}
  15. #latestnews .article-preview{padding-bottom:5px;}
  16. #projects{width:500px; /*background-color:#FF0000;*/ float:left; margin-top:10px; margin-left:10px; margin-right:10px;}
  17. #right{width:470px; float:left; margin-right:10px; /*background-color:#0066CC;*/}
  18. #rss{width:470px; text-align:justify;}
  19. #affilates{width:300px; /*background-color:#0000FF;*/ float:left; margin-top:10px;}


All the rest of the pages seem to look fine in all 3 browsers just the home page is kinda of fouled up. Any help will be greatly appreciated.

Thanks
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • digitalMedia
  • a.k.a. dM
  • Genius
  • User avatar
  • Posts: 5149
  • Loc: SC-USA

Post 3+ Months Ago

I admit, I didn't look at this very thoroughly. Sorry.

Did you try removing the margin-right from #right? Or setting it to zero? It's seems like it isn't needed considering the way you've done the layout...might be causing #right to wrap below #left.
  • CStrauss
  • Graduate
  • Graduate
  • User avatar
  • Posts: 122
  • Loc: St. Louis MO. USA

Post 3+ Months Ago

hmmm honestly I cant remember what I put that 10px right margin, I think I might have done it for a temp padding solution, but none the less i removed that in the #right and it still pushes it below.
  • CStrauss
  • Graduate
  • Graduate
  • User avatar
  • Posts: 122
  • Loc: St. Louis MO. USA

Post 3+ Months Ago

Ok I think I fixed it need to check in IE 7 now but you were on the right track it was something with adding the padding and margins and what not I had to play around with them until I got something that looked good in FF and IE6.

Thanks for looking at that for me

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 54 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.