Design problem in IE

  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8388
  • Loc: USA

Post 3+ Months Ago

The post profile column on my topic views on my forum doesn't show in IE... I don't know what to do or try to get it to show.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Zwirko
  • Guru
  • Guru
  • User avatar
  • Posts: 1417
  • Loc: 55° N, 3° W

Post 3+ Months Ago

Your left_column2 appears to overlapping other block elements nearby and thus confusing IE. Without re-jigging the whole thing you could just add a z-index to leftcolumn2. I tried it quickly with z=3 and it worked.
  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8388
  • Loc: USA

Post 3+ Months Ago

I have already tried that, and already had that when I was making that post... that seemed to solve the problem for the first post only, and after I cleared cache and refreshed, the first post became a problem again...

It doesn't matter what I put for z-index: 3, 10000... it still doesn't work :(
  • Zwirko
  • Guru
  • Guru
  • User avatar
  • Posts: 1417
  • Loc: 55° N, 3° W

Post 3+ Months Ago

OK.

It's such a big css file, that it's very easy to get lost or overlook something. Bearing this in mind, I managed to get your display sorted by changing the following three rules slightly to the following:

Code: [ Select ]
.left_column2 {float: left}
.right_column2 {}
.postbody {padding: 0px; line-height: 1.48em; height: auto; color: #333}
  1. .left_column2 {float: left}
  2. .right_column2 {}
  3. .postbody {padding: 0px; line-height: 1.48em; height: auto; color: #333}


Note that
(1) .right_column2 is no longer floated (in fact, I've removed all its attributes);
(2) .left_column2's only attribute is now just a float left; and
(3) the .postbody no longer has a width attribute.

Some elements seem to have been floated and absolutely positioned at the same time or unnecessarily floated, this is probably part of the problem. I only looked at one page so I don't know if my code re-write has destroyed anything somewhere else.


Almost there I think... ?



Image
  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8388
  • Loc: USA

Post 3+ Months Ago

The reason I had things absolute and floating is because I want the left column being the same size as the right column and have that border all the way across... I am going to go about doing a different solution about this that should work... if it doesn't, I would probably do it the way you did it.

[EDIT:] Nevermind, I just did it the way you posted above... easier and I don't really care about that border... I just think it looks better but w/e. Thanks for the solution :D

Post Information

  • Total Posts in this topic: 5 posts
  • Users browsing this forum: No registered users and 35 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.