Doctype and html 4.01 question

  • techrolla
  • Newbie
  • Newbie
  • techrolla
  • Posts: 8

Post 3+ Months Ago

I am curious as to why my page doesn't render correctly in firefox v0.8 when I have the doctype configured for loose or strict 4.01 HTML? My page seems to lose all css color formatting, although most of the margins and sizes are there. But, when I use HTML 4.0 instead of 4.01, it renders fine and my page validates, any ideas? Here's my site: http://muffinpeddler.dyndns.org
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

When you run it through the validator with the 4.01 doctype, what is the list of errors?
  • techrolla
  • Newbie
  • Newbie
  • techrolla
  • Posts: 8

Post 3+ Months Ago

Okay, with the 4.01 it is valid also, but I think my problem is the css is NOT valid, as I do not use # for hex color values as I should, I will try that and then see what comes of it. Thanks for the reply!
  • ATNO/TW
  • Super Moderator
  • Super Moderator
  • User avatar
  • Posts: 23456
  • Loc: Woodbridge VA

Post 3+ Months Ago

Yes -- even when validating the CSS the w3 validator will give you a list of errors and warnings. All you have to do is correct those and you've got the task accomplished.

Good luck!

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 69 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.